aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2020-08-07 21:19:29 +0200
committerJo-Philipp Wich <jo@mein.io>2020-08-07 21:19:29 +0200
commitbc1c9fdc2075a5f93046be74782be024c4f3fb3f (patch)
treee17ce346fb7dec1eb6b35f221f22dc96b05b90d4 /package
parent321503dbf3d8ac0da8c1693a94a334f8072c72ac (diff)
downloadupstream-bc1c9fdc2075a5f93046be74782be024c4f3fb3f.tar.gz
upstream-bc1c9fdc2075a5f93046be74782be024c4f3fb3f.tar.bz2
upstream-bc1c9fdc2075a5f93046be74782be024c4f3fb3f.zip
hostapd: recognize option "key" as alias for "auth_secret"
The hostapd configuration logic is supposed to accept "option key" as legacy alias for "option auth_secret". This particular fallback option failed to work though because "key" was not a registered configuration variable. Fix this issue by registering the "key" option as well, similar to the existing "server" nad "port" options. Ref: https://github.com/openwrt/openwrt/pull/3282 Suggested-by: Michael Jones <mike@meshplusplus.com> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index b3e93cb770..3aa17b4d3a 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 5cab11022f..fe5b407bc1 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -196,7 +196,7 @@ hostapd_common_add_bss_config() {
config_add_int eapol_version
config_add_string 'auth_server:host' 'server:host'
- config_add_string auth_secret
+ config_add_string auth_secret key
config_add_int 'auth_port:port' 'port:port'
config_add_string acct_server