aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:59 +0000
commitbbece7e4e8303a4fc493a3e944cb9fe53534831c (patch)
tree7965caae18d5ac2f937d7c6dfafce647b91d845d /package
parent42a78d909ed71b79fa75b3b2fcd2facaba334bf8 (diff)
downloadupstream-bbece7e4e8303a4fc493a3e944cb9fe53534831c.tar.gz
upstream-bbece7e4e8303a4fc493a3e944cb9fe53534831c.tar.bz2
upstream-bbece7e4e8303a4fc493a3e944cb9fe53534831c.zip
iptables: add iptables-mod-led (#9400)
SVN-Revision: 27460
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 61739d3551..581c0fcdc4 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -217,6 +217,17 @@ Includes:
- libipt_recent
endef
+define Package/iptables-mod-led
+$(call Package/iptables/Module, +kmod-ipt-led)
+ TITLE:=LED trigger iptables extension
+endef
+
+define Package/iptables-mod-led/description
+iptables extension for triggering a LED.
+Includes:
+- libxt_LED
+endef
+
define Package/iptables-mod-tproxy
$(call Package/iptables/Module, +kmod-ipt-tproxy)
TITLE:=Transparent proxy iptables extensions
@@ -444,6 +455,7 @@ $(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPlugin,iptables-mod-hashlimit,$(IPT_HASHLIMIT-m)))
+$(eval $(call BuildPlugin,iptables-mod-led,$(IPT_LED-m)))
$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))