aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2017-03-14 19:18:57 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-03-15 22:31:11 +0100
commitb6a8b43dd2771d4d237256417218bed862545ef4 (patch)
tree1de72fddbd7dd650a0be48dbf17cd9dc4e805617 /package
parent64170ab9259cf89bd14b83af405f67f0bcdcdd21 (diff)
downloadupstream-b6a8b43dd2771d4d237256417218bed862545ef4.tar.gz
upstream-b6a8b43dd2771d4d237256417218bed862545ef4.tar.bz2
upstream-b6a8b43dd2771d4d237256417218bed862545ef4.zip
toolchain: add musl libc.so to external toolchain
musl provides a /lib/libc.so file which should be integrated into the libc package when the external toolchain with musl is used. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com> Reviewed-by: Florian Fainelli <f.fainelli@gmail.com> Acked-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/libs/toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 8a90b5eda6..0bf482402d 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -164,7 +164,7 @@ define Package/libc/config
string
prompt "libc shared library files (use wildcards)"
depends on EXTERNAL_TOOLCHAIN && PACKAGE_libc
- default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*}"
+ default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*,.so}"
endmenu
endef