aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2020-02-28 08:56:44 -0800
committerPetr Štetiar <ynezz@true.cz>2020-03-01 21:36:00 +0100
commitb56e669af9fdc491d5578e8f02fe06cdb0c290c9 (patch)
tree6e95cb561a9d9b475543301030ca4236ee33b9fd /package
parentb468353a373d181c4362ff690d7b22a08f5f6949 (diff)
downloadupstream-b56e669af9fdc491d5578e8f02fe06cdb0c290c9.tar.gz
upstream-b56e669af9fdc491d5578e8f02fe06cdb0c290c9.tar.bz2
upstream-b56e669af9fdc491d5578e8f02fe06cdb0c290c9.zip
kernel: can: add MCP251x CAN controller module support
Adds kernel module for Microchip MCP251x SPI CAN controller. Signed-off-by: Tim Harvey <tharvey@gateworks.com> [added missing commit description] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/can.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/can.mk b/package/kernel/linux/modules/can.mk
index c2c7411c6e..3bf0359c11 100644
--- a/package/kernel/linux/modules/can.mk
+++ b/package/kernel/linux/modules/can.mk
@@ -146,6 +146,23 @@ endef
$(eval $(call KernelPackage,can-gw))
+define KernelPackage/can-mcp251x
+ TITLE:=MCP251x SPI CAN controller
+ KCONFIG:=\
+ CONFIG_SPI=y \
+ CONFIG_CAN_MCP251X
+ FILES:=$(LINUX_DIR)/drivers/net/can/spi/mcp251x.ko
+ AUTOLOAD:=$(call AutoProbe,can-mcp251x)
+ $(call AddDepends/can)
+endef
+
+define KernelPackage/can-mcp251x/description
+ Microchip MCP251x SPI CAN controller
+endef
+
+$(eval $(call KernelPackage,can-mcp251x))
+
+
define KernelPackage/can-raw
TITLE:=Raw CAN Protcol
KCONFIG:=CONFIG_CAN_RAW