aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-01-24 20:37:09 +0100
committerMathias Kresin <dev@kresin.me>2017-01-25 09:35:04 +0100
commitb52932e773914ee22e848e619d11b4aaf9845feb (patch)
tree42136be870500179d551fee120155ad2ad11bc86 /package
parentd974e5a235759087bfce169cf9cce5a4222b33a3 (diff)
downloadupstream-b52932e773914ee22e848e619d11b4aaf9845feb.tar.gz
upstream-b52932e773914ee22e848e619d11b4aaf9845feb.tar.bz2
upstream-b52932e773914ee22e848e619d11b4aaf9845feb.zip
uboot-lantiq: mark SPL variants as broken
All SPL variants are lzo compressed. The lzop binary is used for compression but is not available in tools. Additionally at least the NAND SPL support is broken and doesn't create working bootloaders. The fb3370 SPI NOR SPL enabled u-boot isn't required for LEDE since the LEDE images are targeting the pre-installed EVA bootloader. Mark these u-boot variants as well as the SPL variants for the reference boards as broken till the lzma issues are fixed upstream and we can use lzma instead of lzo compression. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-lantiq/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index dd101838a1..b16e7cd2b1 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -226,6 +226,7 @@ define U-Boot/easy50712_norspl
BUILD_SUBTARGET:=xway
BUILD_DEVICES:=EASY50712
UBOOT_IMAGE:=u-boot.ltq.lzo.norspl
+ DEPENDS+=@BROKEN
endef
define U-Boot/easy80920_ram
@@ -246,6 +247,7 @@ define U-Boot/easy80920_norspl
BUILD_SUBTARGET:=xrx200
BUILD_DEVICES:=EASY80920NOR EASY80920NAND
UBOOT_IMAGE:=u-boot.ltq.lzo.norspl
+ DEPENDS+=@BROKEN
endef
define U-Boot/easy80920_sfspl
@@ -253,6 +255,7 @@ define U-Boot/easy80920_sfspl
BUILD_SUBTARGET:=xrx200
BUILD_DEVICES:=EASY80920NOR EASY80920NAND
UBOOT_IMAGE:=u-boot.ltq.lzo.sfspl
+ DEPENDS+=@BROKEN
endef
define U-Boot/fb3370_eva
@@ -273,6 +276,7 @@ define U-Boot/fb3370_sfspl
BUILD_SUBTARGET:=xrx200
BUILD_DEVICES:=FRITZ3370
UBOOT_IMAGE:=u-boot.ltq.lzo.sfspl
+ DEPENDS+=@BROKEN
endef
define U-Boot/p2812hnufx_ram
@@ -287,6 +291,7 @@ define U-Boot/p2812hnufx_nandspl
BUILD_SUBTARGET:=xrx200
BUILD_DEVICES:=P2812HNUF1
UBOOT_IMAGE:=u-boot.ltq.lzo.nandspl
+ DEPENDS+=@BROKEN
endef
define U-Boot/vgv7510kw22_brn