aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:42 +0000
commitb38b966a3c62a187026cee48b8da2baf610cee90 (patch)
tree280ddd2b67d0e4ded6089046fb86e5e1acb0f717 /package
parent88223f87d1397efc77d38d2a0894aa4a40413086 (diff)
downloadupstream-b38b966a3c62a187026cee48b8da2baf610cee90.tar.gz
upstream-b38b966a3c62a187026cee48b8da2baf610cee90.tar.bz2
upstream-b38b966a3c62a187026cee48b8da2baf610cee90.zip
package: remove the om2p-watchdog package
Signed-off-by: Antonio Quartulli <ordex@autistici.org> SVN-Revision: 29649
Diffstat (limited to 'package')
-rw-r--r--package/om2p-watchdog/Makefile46
-rwxr-xr-xpackage/om2p-watchdog/files/om2p-watchdog13
-rwxr-xr-xpackage/om2p-watchdog/files/om2p-watchdog.init14
3 files changed, 0 insertions, 73 deletions
diff --git a/package/om2p-watchdog/Makefile b/package/om2p-watchdog/Makefile
deleted file mode 100644
index 965e51f6c3..0000000000
--- a/package/om2p-watchdog/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=om2p-watchdog
-PKG_RELEASE:=1
-PKG_VERSION:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/om2p-watchdog
- SECTION:=base
- CATEGORY:=Base system
- DEPENDS:=@TARGET_ar71xx
- TITLE:=om2p watchdog
- URL:=http://openwrt.org/
-endef
-
-define Package/om2p-watchdog/description
- This package contains the hw watchdog script for the OM2P device.
-endef
-
-define Build/Prepare
-endef
-
-define Build/Compile
-endef
-
-define Build/Compile
-endef
-
-define Package/om2p-watchdog/install
- $(INSTALL_DIR) $(1)/etc/init.d/
- $(INSTALL_DIR) $(1)/sbin/
- $(INSTALL_BIN) ./files/om2p-watchdog.init $(1)/etc/init.d/om2p-watchdog
- $(INSTALL_BIN) ./files/om2p-watchdog $(1)/sbin/om2p-watchdog
-endef
-
-
-$(eval $(call BuildPackage,om2p-watchdog))
-
diff --git a/package/om2p-watchdog/files/om2p-watchdog b/package/om2p-watchdog/files/om2p-watchdog
deleted file mode 100755
index 9f861f6a20..0000000000
--- a/package/om2p-watchdog/files/om2p-watchdog
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-GPIO=12
-
-echo $GPIO > /sys/class/gpio/export
-echo out > /sys/class/gpio/gpio${GPIO}/direction
-
-while true; do
- echo 1 > /sys/class/gpio/gpio${GPIO}/value
- sleep 1
- echo 0 > /sys/class/gpio/gpio${GPIO}/value
- sleep 180
-done
diff --git a/package/om2p-watchdog/files/om2p-watchdog.init b/package/om2p-watchdog/files/om2p-watchdog.init
deleted file mode 100755
index ddec85f7a0..0000000000
--- a/package/om2p-watchdog/files/om2p-watchdog.init
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh /etc/rc.common
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-
-START=11
-
-boot() {
- . /lib/ar71xx.sh
-
- local board=$(ar71xx_board_name)
-
- [ "$board" = "om2p" ] && /sbin/om2p-watchdog &
-}