aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-04-21 00:24:04 +0800
committerJohn Crispin <john@phrozen.org>2018-05-05 08:47:51 +0200
commitb05b16f09b17d119c50b33f60ddb34b2d1958115 (patch)
tree4fcf8a15ea38d6d0dcaf76e203a00b783235f192 /package
parent6e0ae87a987dd61dcfce42dd06b5df845d293307 (diff)
downloadupstream-b05b16f09b17d119c50b33f60ddb34b2d1958115.tar.gz
upstream-b05b16f09b17d119c50b33f60ddb34b2d1958115.tar.bz2
upstream-b05b16f09b17d119c50b33f60ddb34b2d1958115.zip
kernel: Remove AutoLoad for legacy usb gadget modules
These modules usually require some special arguments to customize the emulated device and they should be loaded manually by users. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index be638520aa..f6925fe071 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -131,7 +131,6 @@ define KernelPackage/usb-gadget-ehci-debug
CONFIG_USB_G_DBGP_PRINTK=n
DEPENDS:=+kmod-usb-gadget +kmod-usb-lib-composite +kmod-usb-gadget-serial
FILES:=$(LINUX_DIR)/drivers/usb/gadget/legacy/g_dbgp.ko
- AUTOLOAD:=$(call AutoLoad,52,g_dbgp)
$(call AddDepends/usb)
endef
@@ -154,7 +153,7 @@ define KernelPackage/usb-gadget-eth
$(LINUX_DIR)/drivers/usb/gadget/function/usb_f_ecm_subset.ko \
$(LINUX_DIR)/drivers/usb/gadget/function/usb_f_rndis.ko \
$(LINUX_DIR)/drivers/usb/gadget/legacy/g_ether.ko
- AUTOLOAD:=$(call AutoLoad,52,usb_f_ecm g_ether)
+ AUTOLOAD:=$(call AutoLoad,52,usb_f_ecm)
$(call AddDepends/usb)
endef
@@ -175,7 +174,7 @@ define KernelPackage/usb-gadget-serial
$(LINUX_DIR)/drivers/usb/gadget/function/usb_f_obex.ko \
$(LINUX_DIR)/drivers/usb/gadget/function/usb_f_serial.ko \
$(LINUX_DIR)/drivers/usb/gadget/legacy/g_serial.ko
- AUTOLOAD:=$(call AutoLoad,52,usb_f_acm g_serial)
+ AUTOLOAD:=$(call AutoLoad,52,usb_f_acm)
$(call AddDepends/usb)
endef
@@ -192,7 +191,7 @@ define KernelPackage/usb-gadget-mass-storage
FILES:= \
$(LINUX_DIR)/drivers/usb/gadget/function/usb_f_mass_storage.ko \
$(LINUX_DIR)/drivers/usb/gadget/legacy/g_mass_storage.ko
- AUTOLOAD:=$(call AutoLoad,52,usb_f_mass_storage g_mass_storage)
+ AUTOLOAD:=$(call AutoLoad,52,usb_f_mass_storage)
$(call AddDepends/usb)
endef