aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-01-01 12:47:11 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-02-08 00:57:14 +0000
commitaed95c4cb8d5a55a795910a759d08e1393f8d967 (patch)
tree9751fbfb0f7475fcce4544934d6e71ac413ac4ac /package
parent29a6a71d52738af9552bd77763f10e912a7eb9f0 (diff)
downloadupstream-aed95c4cb8d5a55a795910a759d08e1393f8d967.tar.gz
upstream-aed95c4cb8d5a55a795910a759d08e1393f8d967.tar.bz2
upstream-aed95c4cb8d5a55a795910a759d08e1393f8d967.zip
dnsmasq: switch to ubus-based hotplug call
Use new ubus-based hotplug call in dhcp-script.sh As sysntpd now makes use of the new ubus-based hotplug calls, dnsmasq no longer needs to ship ACL to cover ntpd-hotplug. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/dnsmasq/Makefile3
-rwxr-xr-xpackage/network/services/dnsmasq/files/dhcp-script.sh63
-rw-r--r--package/network/services/dnsmasq/files/dnsmasq_acl.json10
-rw-r--r--package/network/services/dnsmasq/files/dnsmasqsec.hotplug1
-rw-r--r--package/network/services/dnsmasq/files/dnsmasqsec_hotplug_acl.json8
5 files changed, 46 insertions, 39 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 2e404dfef3..45badd31dc 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_UPSTREAM_VERSION:=2.84test3
PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/test-releases
@@ -180,7 +180,6 @@ define Package/dnsmasq/install
$(INSTALL_BIN) ./files/dhcp-script.sh $(1)/usr/lib/dnsmasq/dhcp-script.sh
$(INSTALL_DIR) $(1)/usr/share/acl.d
$(INSTALL_DATA) ./files/dnsmasq_acl.json $(1)/usr/share/acl.d/
- $(INSTALL_DATA) ./files/dnsmasqsec_hotplug_acl.json $(1)/usr/share/acl.d/
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/50-dnsmasq-migrate-resolv-conf-auto.sh $(1)/etc/uci-defaults
endef
diff --git a/package/network/services/dnsmasq/files/dhcp-script.sh b/package/network/services/dnsmasq/files/dhcp-script.sh
index 86032694c1..470097bf6b 100755
--- a/package/network/services/dnsmasq/files/dhcp-script.sh
+++ b/package/network/services/dnsmasq/files/dhcp-script.sh
@@ -2,45 +2,52 @@
[ -f "$USER_DHCPSCRIPT" ] && . "$USER_DHCPSCRIPT" "$@"
+. /usr/share/libubox/jshn.sh
+
+json_init
+json_add_array env
+hotplugobj=""
+
+case "$1" in
+ add | del | old | arp-add | arp-del)
+ json_add_string "" "MACADDR=$2"
+ json_add_string "" "IPADDR=$3"
+ ;;
+esac
+
case "$1" in
add)
- export ACTION="add"
- export MACADDR="$2"
- export IPADDR="$3"
- export HOSTNAME="$4"
- exec /sbin/hotplug-call dhcp
+ json_add_string "" "ACTION=add"
+ json_add_string "" "HOSTNAME=$4"
+ hotplugobj="dhcp"
;;
del)
- export ACTION="remove"
- export MACADDR="$2"
- export IPADDR="$3"
- export HOSTNAME="$4"
- exec /sbin/hotplug-call dhcp
+ json_add_string "" "ACTION=remove"
+ json_add_string "" "HOSTNAME=$4"
+ hotplugobj="dhcp"
;;
old)
- export ACTION="update"
- export MACADDR="$2"
- export IPADDR="$3"
- export HOSTNAME="$4"
- exec /sbin/hotplug-call dhcp
+ json_add_string "" "ACTION=update"
+ json_add_string "" "HOSTNAME=$4"
+ hotplugobj="dhcp"
;;
arp-add)
- export ACTION="add"
- export MACADDR="$2"
- export IPADDR="$3"
- exec /sbin/hotplug-call neigh
+ json_add_string "" "ACTION=add"
+ hotplugobj="neigh"
;;
arp-del)
- export ACTION="remove"
- export MACADDR="$2"
- export IPADDR="$3"
- exec /sbin/hotplug-call neigh
+ json_add_string "" "ACTION=remove"
+ hotplugobj="neigh"
;;
tftp)
- export ACTION="add"
- export TFTP_SIZE="$2"
- export TFTP_ADDR="$3"
- export TFTP_PATH="$4"
- exec /sbin/hotplug-call tftp
+ json_add_string "" "ACTION=add"
+ json_add_string "" "TFTP_SIZE=$2"
+ json_add_string "" "TFTP_ADDR=$3"
+ json_add_string "" "TFTP_PATH=$4"
+ hotplugobj="tftp"
;;
esac
+
+json_close_array env
+
+[ -n "$hotplugobj" ] && ubus call hotplug.${hotplugobj} call "$(json_dump)"
diff --git a/package/network/services/dnsmasq/files/dnsmasq_acl.json b/package/network/services/dnsmasq/files/dnsmasq_acl.json
index 00ec7d0f03..47d7c29302 100644
--- a/package/network/services/dnsmasq/files/dnsmasq_acl.json
+++ b/package/network/services/dnsmasq/files/dnsmasq_acl.json
@@ -1,4 +1,12 @@
{
"user": "dnsmasq",
- "publish": [ "dnsmasq" ]
+ "publish": [ "dnsmasq" ],
+ "access": {
+ "hotplug.dhcp": {
+ "methods": [ "call" ]
+ },
+ "hotplug.neigh": {
+ "methods": [ "call" ]
+ }
+ }
}
diff --git a/package/network/services/dnsmasq/files/dnsmasqsec.hotplug b/package/network/services/dnsmasq/files/dnsmasqsec.hotplug
index 71f5e68b2d..a59148600b 100644
--- a/package/network/services/dnsmasq/files/dnsmasqsec.hotplug
+++ b/package/network/services/dnsmasq/files/dnsmasqsec.hotplug
@@ -5,6 +5,7 @@ TIMEVALIDFILE="/var/state/dnsmasqsec"
[ -f "$TIMEVALIDFILE" ] || {
echo "ntpd says time is valid" >$TIMEVALIDFILE
/etc/init.d/dnsmasq enabled && {
+ initscript=dnsmasq
. /lib/functions/procd.sh
procd_send_signal dnsmasq '*' INT
}
diff --git a/package/network/services/dnsmasq/files/dnsmasqsec_hotplug_acl.json b/package/network/services/dnsmasq/files/dnsmasqsec_hotplug_acl.json
deleted file mode 100644
index 861ecbe034..0000000000
--- a/package/network/services/dnsmasq/files/dnsmasqsec_hotplug_acl.json
+++ /dev/null
@@ -1,8 +0,0 @@
-{
- "user": "ntp",
- "access": {
- "service": {
- "methods": [ "signal" ]
- }
- }
-}