aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-07-20 01:54:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-07-20 01:54:16 +0000
commitae2c9dcb2b682a06e6e4d18246fa36b9c5214df1 (patch)
tree75e445d30c1124435ceec588e9672953dd39977a /package
parentbced5d7d74076dafe468e626200ce760f06ffa39 (diff)
downloadupstream-ae2c9dcb2b682a06e6e4d18246fa36b9c5214df1.tar.gz
upstream-ae2c9dcb2b682a06e6e4d18246fa36b9c5214df1.tar.bz2
upstream-ae2c9dcb2b682a06e6e4d18246fa36b9c5214df1.zip
move the crda dependency to the kmod-cfg80211 package, get rid of crda's dependency on mac80211. this fixes circular dependency issues
SVN-Revision: 22304
Diffstat (limited to 'package')
-rw-r--r--package/crda/Makefile2
-rw-r--r--package/hostapd/Makefile2
-rw-r--r--package/mac80211/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/crda/Makefile b/package/crda/Makefile
index 7036dcfd6f..9e9be188ff 100644
--- a/package/crda/Makefile
+++ b/package/crda/Makefile
@@ -28,7 +28,7 @@ define Package/crda
SECTION:=net
CATEGORY:=Network
TITLE:=Central Regulatory Domain Agent (CRDA)
- DEPENDS:=+kmod-mac80211 +libnl-tiny
+ DEPENDS:=+libnl-tiny
URL:=http://wireless.kernel.org/en/developers/Regulatory/CRDA
endef
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 3e4864dcc0..5bcaba9458 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -82,7 +82,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif
-DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
+DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
define Package/hostapd/Default
SECTION:=net
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 050447d052..03a1a4b0db 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -41,7 +41,7 @@ endef
define KernelPackage/cfg80211
$(call KernelPackage/mac80211/Default)
TITLE:=cfg80211 - wireless configuration API
- DEPENDS+= +wireless-tools +iw @!LINUX_2_6_25
+ DEPENDS+= +wireless-tools +iw @!LINUX_2_6_25 +crda
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.33)),1)
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.ko \