aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMantas Pucka <mantas@8devices.com>2019-02-25 18:29:13 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-26 23:20:04 +0100
commitabf445f189f1c18d0eaeebc7dcc8ab1948349c2e (patch)
treea2ea677817090e4f6577699e24cb9a53c9520612 /package
parentb55fbb6b2dfb2eb15159f3e55e17694cbaa5ce32 (diff)
downloadupstream-abf445f189f1c18d0eaeebc7dcc8ab1948349c2e.tar.gz
upstream-abf445f189f1c18d0eaeebc7dcc8ab1948349c2e.tar.bz2
upstream-abf445f189f1c18d0eaeebc7dcc8ab1948349c2e.zip
Revert "iw: compile with LTO enabled"
After update to 5.0.1 iw-full package failed to display command list on ipq40xx arch. Root cause was found to be LTO reordering causing incorrect detection of command struct size in: iw.c:552 cmd_size = labs((long)&__section_set - (long)&__section_get); This reverts commit ef16a394d2b24a363b50b5b4720cb23fe156c9da. Signed-off-by: Mantas Pucka <mantas@8devices.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iw/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/network/utils/iw/Makefile b/package/network/utils/iw/Makefile
index 4b1542e967..58cf8319f5 100644
--- a/package/network/utils/iw/Makefile
+++ b/package/network/utils/iw/Makefile
@@ -47,8 +47,7 @@ TARGET_CPPFLAGS:= \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
$(TARGET_CPPFLAGS) \
-DCONFIG_LIBNL20 \
- -D_GNU_SOURCE \
- -flto
+ -D_GNU_SOURCE
ifeq ($(BUILD_VARIANT),full)
TARGET_CPPFLAGS += -DIW_FULL
@@ -57,7 +56,7 @@ endif
MAKE_FLAGS += \
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -ffunction-sections -fdata-sections" \
- LDFLAGS="$(TARGET_LDFLAGS) -Wl,--gc-sections -flto" \
+ LDFLAGS="$(TARGET_LDFLAGS) -Wl,--gc-sections" \
NL1FOUND="" NL2FOUND=Y \
NLLIBNAME="libnl-tiny" \
LIBS="-lm -lnl-tiny" \