aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-06 00:11:56 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:19:44 +0100
commita4cdb537b17ede9785ddbaef5ed9d69f3ab89052 (patch)
tree370cc5b2eda165713da31bffa2a2e2b040e463ff /package
parentc642a97aa6b51352a718449cd715b92f94af4a5d (diff)
downloadupstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.gz
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.bz2
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.zip
sunxi: use vendor_device scheme for device definitions
This changes device definition to resemble the vendor_device scheme already present for the majority of device compatible strings. By doing this, we achieve several advantages at once: - Image names and node names are more consistent with other targets. - SUPPORTED_DEVICES can be set automatically for all but two cases. - Image names and node names are in line with DEVICE_TITLEs. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-sunxi/Makefile68
1 files changed, 34 insertions, 34 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 2c414f8c9e..ce39fe792d 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -28,67 +28,67 @@ endef
define U-Boot/A10-OLinuXino-Lime
BUILD_SUBTARGET:=cortexa8
NAME:=A10 OLinuXino LIME
- BUILD_DEVICES:=sun4i-a10-olinuxino-lime
+ BUILD_DEVICES:=olimex_a10-olinuxino-lime
endef
define U-Boot/A13-OLinuXino
BUILD_SUBTARGET:=cortexa8
NAME:=A13 OlinuXino
- BUILD_DEVICES:=sun5i-a13-olinuxino
+ BUILD_DEVICES:=olimex_a13-olinuxino
endef
define U-Boot/A20-OLinuXino-Lime
BUILD_SUBTARGET:=cortexa7
NAME:=A20 OLinuXino LIME
- BUILD_DEVICES:=sun7i-a20-olinuxino-lime
+ BUILD_DEVICES:=olimex_a20-olinuxino-lime
endef
define U-Boot/A20-OLinuXino-Lime2
BUILD_SUBTARGET:=cortexa7
NAME:=A20 OLinuXino LIME2
- BUILD_DEVICES:=sun7i-a20-olinuxino-lime2
+ BUILD_DEVICES:=olimex_a20-olinuxino-lime2
endef
define U-Boot/A20-OLinuXino-Lime2-eMMC
BUILD_SUBTARGET:=cortexa7
NAME:=A20 OLinuXino LIME2 eMMC
- BUILD_DEVICES:=sun7i-a20-olinuxino-lime2-emmc
+ BUILD_DEVICES:=olimex_a20-olinuxino-lime2-emmc
endef
define U-Boot/A20-OLinuXino_MICRO
BUILD_SUBTARGET:=cortexa7
NAME:=A20 OLinuXino MICRO
- BUILD_DEVICES:=sun7i-a20-olinuxino-micro
+ BUILD_DEVICES:=olimex_a20-olinuxino-micro
endef
define U-Boot/Bananapi
BUILD_SUBTARGET:=cortexa7
NAME:=Bananapi
- BUILD_DEVICES:=sun7i-a20-bananapi
+ BUILD_DEVICES:=lemaker_bananapi
endef
define U-Boot/Bananapro
BUILD_SUBTARGET:=cortexa7
NAME:=Bananapro
- BUILD_DEVICES:=sun7i-a20-bananapro
+ BUILD_DEVICES:=lemaker_bananapro
endef
define U-Boot/Cubieboard
BUILD_SUBTARGET:=cortexa8
NAME:=Cubieboard
- BUILD_DEVICES:=sun4i-a10-cubieboard
+ BUILD_DEVICES:=cubietech_a10-cubieboard
endef
define U-Boot/Cubieboard2
BUILD_SUBTARGET:=cortexa7
NAME:=Cubieboard2
- BUILD_DEVICES:=sun7i-a20-cubieboard2
+ BUILD_DEVICES:=cubietech_cubieboard2
endef
define U-Boot/Cubietruck
BUILD_SUBTARGET:=cortexa7
NAME:=Cubietruck
- BUILD_DEVICES:=sun7i-a20-cubietruck
+ BUILD_DEVICES:=cubietech_cubietruck
endef
define U-Boot/Hummingbird_A31
@@ -99,91 +99,91 @@ endef
define U-Boot/Marsboard_A10
BUILD_SUBTARGET:=cortexa8
NAME:=Marsboard
- BUILD_DEVICES:=sun4i-a10-marsboard
+ BUILD_DEVICES:=marsboard_a10-marsboard
endef
define U-Boot/Mele_M9
BUILD_SUBTARGET:=cortexa7
NAME:=Mele M9 (A31)
- BUILD_DEVICES:=sun6i-a31-m9
+ BUILD_DEVICES:=mele_m9
endef
define U-Boot/OLIMEX_A13_SOM
BUILD_SUBTARGET:=cortexa8
NAME:=Olimex A13 SOM
- BUILD_DEVICES:=sun5i-a13-olimex-som
+ BUILD_DEVICES:=olimex_a13-olimex-som
endef
define U-Boot/Linksprite_pcDuino
BUILD_SUBTARGET:=cortexa8
NAME:=Linksprite pcDuino
- BUILD_DEVICES:=sun4i-a10-pcduino
+ BUILD_DEVICES:=linksprite_a10-pcduino
endef
define U-Boot/Linksprite_pcDuino3
BUILD_SUBTARGET:=cortexa7
NAME:=Linksprite pcDuino3
- BUILD_DEVICES:=sun7i-a20-pcduino3
+ BUILD_DEVICES:=linksprite_pcduino3
endef
define U-Boot/Lamobo_R1
BUILD_SUBTARGET:=cortexa7
NAME:=Lamobo R1
- BUILD_DEVICES:=sun7i-a20-lamobo-r1
+ BUILD_DEVICES:=lamobo_lamobo-r1
endef
define U-Boot/nanopi_m1_plus
BUILD_SUBTARGET:=cortexa7
NAME:=NanoPi M1 Plus (H3)
- BUILD_DEVICES:=sun8i-h3-nanopi-m1-plus
+ BUILD_DEVICES:=friendlyarm_nanopi-m1-plus
endef
define U-Boot/nanopi_neo
BUILD_SUBTARGET:=cortexa7
NAME:=U-Boot for NanoPi NEO (H3)
- BUILD_DEVICES:=sun8i-h3-nanopi-neo
+ BUILD_DEVICES:=friendlyarm_nanopi-neo
endef
define U-Boot/orangepi_r1
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi R1 (H2+)
- BUILD_DEVICES:=sun8i-h2-plus-orangepi-r1
+ BUILD_DEVICES:=xunlong_orangepi-r1
endef
define U-Boot/orangepi_zero
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi Zero (H2+)
- BUILD_DEVICES:=sun8i-h2-plus-orangepi-zero
+ BUILD_DEVICES:=xunlong_orangepi-zero
endef
define U-Boot/orangepi_one
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi One (H3)
- BUILD_DEVICES:=sun8i-h3-orangepi-one
+ BUILD_DEVICES:=xunlong_orangepi-one
endef
define U-Boot/orangepi_pc
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC (H3)
- BUILD_DEVICES:=sun8i-h3-orangepi-pc
+ BUILD_DEVICES:=xunlong_orangepi-pc
endef
define U-Boot/orangepi_pc_plus
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC Plus (H3)
- BUILD_DEVICES:=sun8i-h3-orangepi-pc-plus
+ BUILD_DEVICES:=xunlong_orangepi-pc-plus
endef
define U-Boot/orangepi_plus
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi Plus (H3)
- BUILD_DEVICES:=sun8i-h3-orangepi-plus
+ BUILD_DEVICES:=xunlong_orangepi-plus
endef
define U-Boot/orangepi_2
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi 2 (H3)
- BUILD_DEVICES:=sun8i-h3-orangepi-2
+ BUILD_DEVICES:=xunlong_orangepi-2
endef
define U-Boot/pangolin
@@ -195,7 +195,7 @@ endef
define U-Boot/nanopi_neo_plus2
BUILD_SUBTARGET:=cortexa53
NAME:=NanoPi NEO Plus2 (H5)
- BUILD_DEVICES:=sun50i-h5-nanopi-neo-plus2
+ BUILD_DEVICES:=friendlyarm_nanopi-neo-plus2
DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
UENV:=a64
endef
@@ -203,7 +203,7 @@ endef
define U-Boot/nanopi_neo2
BUILD_SUBTARGET:=cortexa53
NAME:=NanoPi NEO2 (H5)
- BUILD_DEVICES:=sun50i-h5-nanopi-neo2
+ BUILD_DEVICES:=friendlyarm_nanopi-neo2
DEPENDS:=+PACKAGE_u-boot-nanopi_neo2:arm-trusted-firmware-sunxi
UENV:=a64
endef
@@ -211,7 +211,7 @@ endef
define U-Boot/pine64_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Pine64 Plus A64
- BUILD_DEVICES:=sun50i-a64-pine64-plus
+ BUILD_DEVICES:=pine64_pine64-plus
DEPENDS:=+PACKAGE_u-boot-pine64_plus:arm-trusted-firmware-sunxi
UENV:=a64
endef
@@ -219,13 +219,13 @@ endef
define U-Boot/Sinovoip_BPI_M2_Plus
BUILD_SUBTARGET:=cortexa7
NAME:=Bananapi M2 Plus
- BUILD_DEVICES:=sun8i-h3-bananapi-m2-plus
+ BUILD_DEVICES:=sinovoip_bananapi-m2-plus
endef
define U-Boot/sopine_baseboard
BUILD_SUBTARGET:=cortexa53
NAME:=Sopine Baseboard
- BUILD_DEVICES:=sun50i-a64-sopine-baseboard
+ BUILD_DEVICES:=pine64_sopine-baseboard
DEPENDS:=+PACKAGE_u-boot-sopine_baseboard:arm-trusted-firmware-sunxi
UENV:=a64
endef
@@ -234,7 +234,7 @@ endef
define U-Boot/orangepi_zero_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Xunlong Orange Pi Zero Plus
- BUILD_DEVICES:=sun50i-h5-orangepi-zero-plus
+ BUILD_DEVICES:=xunlong_orangepi-zero-plus
DEPENDS:=+PACKAGE_u-boot-orangepi_zero_plus:arm-trusted-firmware-sunxi
UENV:=a64
endef
@@ -242,7 +242,7 @@ endef
define U-Boot/orangepi_pc2
BUILD_SUBTARGET:=cortexa53
NAME:=Xunlong Orange Pi PC2
- BUILD_DEVICES:=sun50i-h5-orangepi-pc2
+ BUILD_DEVICES:=xunlong_orangepi-pc2
DEPENDS:=+PACKAGE_u-boot-orangepi_pc2:arm-trusted-firmware-sunxi
UENV:=a64
endef
@@ -250,7 +250,7 @@ endef
define U-Boot/Sinovoip_BPI_M2_Ultra
BUILD_SUBTARGET:=cortexa7
NAME:=Bananapi M2 Ultra
- BUILD_DEVICES:=sun8i-r40-bananapi-m2-ultra
+ BUILD_DEVICES:=lemaker_bananapi-m2-ultra
endef
UBOOT_TARGETS := \