aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-06-07 19:07:14 +0200
committerFelix Fietkau <nbd@nbd.name>2019-06-25 13:24:49 +0200
commita0e5ca4f3523b9eef96bff32e45f6fa8275b982f (patch)
tree0ab4e4fbb1a0043843335fdfba043da3dc70f060 /package
parente08296a8517d0e0da44afe3689775f6a00bdf57a (diff)
downloadupstream-a0e5ca4f3523b9eef96bff32e45f6fa8275b982f.tar.gz
upstream-a0e5ca4f3523b9eef96bff32e45f6fa8275b982f.tar.bz2
upstream-a0e5ca4f3523b9eef96bff32e45f6fa8275b982f.zip
mt76: update to the latest version, adds preliminary mt7615 support
b3a2965 mt76x02: fix crash on device reset ffddb68 mt76x02u: check chip version on probe 7fc5f92 mt76x2u: remove duplicated entry in mt76x2u_device_table 61311d9 mt76: introduce mt76_free_device routine a7dfcf2 mt76: move mac_work in mt76_dev 334b4ce mt76: add mac80211 driver for MT7615 PCIe-based chipsets edb2a00 mt76: add unlikely() for dma_mapping_error() check 355c079 mt76: use macro for sn and seq_ctrl conversion 133bffb add firmware for MT7615E 49d9c1b mt76: usb: reduce locking in mt76u_tx_tasklet 3e371ca mt76: set txwi_size according to the driver value 5007326 mt76: add skb pointer to mt76_tx_info c47a568 mt76: dma: introduce skb field in mt76_txwi_cache 9029560 mt76: dma: add skb check for dummy pointer e9eea39 mt76: mt7615: use sizeof instead of sizeof_field 98c5359 Revert "mt76: fix potential deadlock on cancelling workqueues" bc9baa7 mt76x02u: remove bogus stop on suspend 6c1cab9 mt76usb: fix tx/rx stop 0e674c5 mt76x02: remove bogus mutex usage 59f7bb6 Revert "mt76: mt76x02: send no-skb tx status without holding the status lock" b0f2a30 mt76x02: avoid status_list.lock and sta->rate_ctrl_lock dependency 62054de mt76: mt7603: remove query from mt7603_mcu_msg_send signature e79d96a mt76: mt7603: use standard signature for mt7603_mcu_msg_send be8f039 mt76: mt7603: initialize mt76_mcu_ops data structure 9a9c656 mt76: introduce mt76_mcu_restart macro 980b91e mt76: mt7603: init mcu_restart function pointer a97db3f mt76: mt7603: run __mt76_mcu_send_msg in mt7603_mcu_send_firmware 151115f mt76: mt76x02: mt76x02_poll_tx() can be static 7391f98 mt76: fix endianness sparse warnings 6c06f73 mt76: mt7603: report firmware version using ethtool f06647e mt76: usb: use EP max packet aligned buffer sizes for rx f43fccf mt76: move beacon_int in mt76_dev 74ab2cf mt76: move beacon_mask in mt76_dev 23c2f94 mt76: add TX/RX antenna pattern capabilities 6e790e1 mt76: move pre_tbtt_tasklet in mt76_dev 7606c08 mt76: mt7603: enable/disable pre_tbtt_tasklet in mt7603_set_channel ff22eee mt76: do not enable/disable pre_tbtt_tasklet in scan_start/scan_complete 3157385 mt76: mt7603: dynamically alloc mcu req in mt7603_mcu_set_eeprom cc674e2 mt76: mt76x02: remove useless return in mt76x02_resync_beacon_timer 6b18427 mt76: move tx_napi in mt76_dev bce63c4 mt76: mt7603: use napi polling for tx cleanup 4afd89e mt76: mt7615: use napi polling for tx cleanup 2cb4683 mt76: move netif_napi_del in mt76_dma_cleanup b4ceb9f mt76: Fix a signedness bug in mt7615_add_interface() d00dc95 mt76: mt7615: Use after free in mt7615_mcu_set_bcn() 4e0ccc6 mt76: mt7615: Make mt7615_irq_handler static 0fd552a mt7615: mcu: simplify __mt7615_mcu_set_wtbl 50f7094 mt7615: mcu: simplify __mt7615_mcu_set_sta_rec 4434d04 mt7615: mcu: remove bss_info_convert_vif_type routine 083fbb9 mt7615: mcu: use proper msg size in mt7615_mcu_add_wtbl_bmc f61ca80 mt7615: mcu: use proper msg size in mt7615_mcu_add_wtbl 35bd12d mt7615: mcu: unify mt7615_mcu_add_wtbl_bmc and mt7615_mcu_del_wtbl_bmc f8f990b mt7615: mcu: remove unused parameter in mt7615_mcu_del_wtbl 965bca1 mt7615: remove query from mt7615_mcu_msg_send signature 9b9ca18 mt7615: remove dest from mt7615_mcu_msg_send signature 935b7e5 mt7615: mcu: remove skb_ret from mt7615_mcu_msg_send 2442db4 mt7615: mcu: unify __mt7615_mcu_set_dev_info and mt7615_mcu_set_dev_info 645bc45 mt7615: mcu: do not use function pointers whenever possible 40c4201 mt7615: mcu: remove unused structure in mcu.h a8834a2 mt7615: mcu: use standard signature for mt7615_mcu_msg_send 824d25c mt7615: initialize mt76_mcu_ops data structure d943427 mt7615: mcu: init mcu_restart function pointer c2211e4 mt7615: mcu: run __mt76_mcu_send_msg in mt7615_mcu_send_firmware cb63a06 mt76: mt7603: stop mac80211 queues before setting the channel c6aaa3a mt76: mt7615: rearrange cleanup operations in mt7615_unregister_device 97609f3 mt76: mt7615: add static qualifier to mt7615_rx_poll_complete f9dadd2 mt76: mt7603: add debugfs knob to enable/disable edcca 89cda5d mt7603: fix reading target tx power from eeprom 77d0e33 mt76: fix setting chan->max_power f575da2 mt76: mt76x02: fix tx status reporting issues a5d18dc mt76: mt76x02: fix tx reordering on rate control probing without a-mpdu bd32a93 mt76: mt76x02: remove enable from mt76x02_edcca_init signature 18386ee mt76: mt76x2u: remove mt76x02_edcca_init in mt76x2u_set_channel da3514f mt76: mt76x2: move mutex_lock inside mt76x2_set_channel 0d4719c mt76: mt76x02: run mt76x02_edcca_init atomically in mt76_edcca_set fd5af73 mt76: mt76x02: fix edcca file permission a0f51f2 mt76: mt7615: do not process rx packets if the device is not initialized 753cdee mt76: mt7615: stop mcu first in mt7615_unregister_device 899efe7 mt76: move mt76_insert_ccmp_hdr in mt76-module 6960b6e mt76: mt7615: add support for mtd eeprom parsing 4bcb057 mt76: mt7615: select wifi band according to eeprom 866f2c6 mt76: generalize mt76_get_txpower for 4x4:4 devices 514fb04 mt76: mt7615: add the capability to configure tx power ced9d43 mt76: mt7615: init get_txpower mac80211 callback 8abd502 mt76: mt7615: rearrange locking in mt7615_config 5b9b62e mt76: move mt76_get_rate in mt76-module 661c7c8 mt76: Remove set but not used variables 'pid' and 'final_mpdu' f072c7b mt76: mt7615: enable support for mesh 28d9496 mt76: mt7615: fix slow performance when enable encryption 827b9ad mt76: mt7615: remove unused variable in mt7615_mcu_set_bcn 34eea14 mt76: mt7615: remove key check in mt7615_mcu_set_wtbl_key 2bfae5a mt76: usb: fix rx A-MSDU support b033532 mt76: usb: do not always copy the first part of received frames 3e7fc15 mt76x02: fix reporting of non-probing frames with tx status requested 0d5caea Revert "mt76: usb: do not always copy the first part of received frames" 335e8c6 Revert "mt76: usb: fix rx A-MSDU support" 47ddf4b mt76: revert support for TX_NEEDS_ALIGNED4_SKBS 0b6520b mt7603: rework and fix tx status reporting 539b679 mt7603: improve hardware rate switching configuration d86d6ef mt76x0: fix RF frontend initialization for external PA f476a14 mt76x02: fix endian issue in tx status reporting patch f8d0517 mt76: mt7615: simplify mt7615_mcu_set_sta_rec routine 73ff45f mt76: mt7615: add support for per-chain signal strength reporting 9b67ae6 mt76: mt7615: init per-channel target power 160fdc0 mt76: mt7615: take into account extPA when configuring tx power 2211d93 mt76: mt76x02u: fix sparse warnings: should it be static? 3750533 mt76: mt7615: fix incorrect settings in mesh mode c37c1ca mt76: mt7615: update peer's bssid when state transition occurs 9dd1089 mt76: mt76u: reduce rx memory footprint 0789f45 mt76: mt7615: remove cfg80211_chan_def from mt7615_set_channel signature 2dca431 mt76: move nl80211_dfs_regions in mt76_dev data structure 3386ccf mt76: mt76u: get rid of {out,in}_max_packet d680ab0 mt76: usb: fix rx A-MSDU support Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mt76/Makefile28
1 files changed, 25 insertions, 3 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index a985f90b2a..89dcddc164 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-03-27
-PKG_SOURCE_VERSION:=a11b67348aeb2d3175c5995c747e7fc050c7df60
-PKG_MIRROR_HASH:=6ea603308fa568c8ab39eddd86d9c8110a10aa93971348f52ceda0e5bd423ec6
+PKG_SOURCE_DATE:=2019-06-25
+PKG_SOURCE_VERSION:=d680ab01cddd4aea1849363e0ef84df45d538fd5
+PKG_MIRROR_HASH:=be9deb1ed96cabf41010723caee9babf51ed3f70b31c48c63d649c85b07ab64e
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_BUILD_PARALLEL:=1
@@ -138,6 +138,15 @@ define KernelPackage/mt7603
AUTOLOAD:=$(call AutoProbe,mt7603e)
endef
+define KernelPackage/mt7615e
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT7615 wireless driver
+ DEPENDS+=@PCI_SUPPORT +kmod-mt76-core
+ FILES:=\
+ $(PKG_BUILD_DIR)/mt7615/mt7615e.ko
+ AUTOLOAD:=$(call AutoProbe,mt7615e)
+endef
+
NOSTDINC_FLAGS = \
-I$(PKG_BUILD_DIR) \
-I$(STAGING_DIR)/usr/include/mac80211-backport/uapi \
@@ -181,6 +190,9 @@ endif
ifdef CONFIG_PACKAGE_kmod-mt7603
PKG_MAKE_FLAGS += CONFIG_MT7603E=m
endif
+ifdef CONFIG_PACKAGE_kmod-mt7615e
+ PKG_MAKE_FLAGS += CONFIG_MT7615E=m
+endif
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
@@ -233,6 +245,15 @@ define KernelPackage/mt7603/install
$(1)/lib/firmware
endef
+define KernelPackage/mt7615e/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ cp \
+ $(PKG_BUILD_DIR)/firmware/mt7615_cr4.bin \
+ $(PKG_BUILD_DIR)/firmware/mt7615_n9.bin \
+ $(PKG_BUILD_DIR)/firmware/mt7615_rom_patch.bin \
+ $(1)/lib/firmware
+endef
+
$(eval $(call KernelPackage,mt76-core))
$(eval $(call KernelPackage,mt76-usb))
$(eval $(call KernelPackage,mt76x02-usb))
@@ -244,4 +265,5 @@ $(eval $(call KernelPackage,mt76x2-common))
$(eval $(call KernelPackage,mt76x2u))
$(eval $(call KernelPackage,mt76x2))
$(eval $(call KernelPackage,mt7603))
+$(eval $(call KernelPackage,mt7615e))
$(eval $(call KernelPackage,mt76))