aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
commita0c49ef46f7caf5eb02c635d446218201008ecff (patch)
treea94180d50839c1587dfe845e8faf16405fab78ff /package
parent518ab154e059c9f39684f8c78159c9caf333716b (diff)
downloadupstream-a0c49ef46f7caf5eb02c635d446218201008ecff.tar.gz
upstream-a0c49ef46f7caf5eb02c635d446218201008ecff.tar.bz2
upstream-a0c49ef46f7caf5eb02c635d446218201008ecff.zip
generic: add linux 4.1 support
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46112
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/block.mk2
-rw-r--r--package/kernel/linux/modules/can.mk2
-rw-r--r--package/kernel/linux/modules/fs.mk1
-rw-r--r--package/kernel/linux/modules/other.mk12
4 files changed, 15 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 2d79e51021..afa0cd3349 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -267,6 +267,8 @@ define KernelPackage/dm
CONFIG_DM_DEBUG=n \
CONFIG_DM_UEVENT=n \
CONFIG_DM_DELAY=n \
+ CONFIG_DM_LOG_WRITES=n \
+ CONFIG_DM_MQ_DEFAULT=n \
CONFIG_DM_MULTIPATH=n \
CONFIG_DM_ZERO=n \
CONFIG_DM_SNAPSHOT=n \
diff --git a/package/kernel/linux/modules/can.mk b/package/kernel/linux/modules/can.mk
index 9245490a20..f9490b40d4 100644
--- a/package/kernel/linux/modules/can.mk
+++ b/package/kernel/linux/modules/can.mk
@@ -240,7 +240,7 @@ $(eval $(call KernelPackage,can-c-can))
define KernelPackage/can-c-can-platform
TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
- DEPENDS:=kmod-can-c-can
+ DEPENDS:=kmod-can-c-can +LINUX_4_1:kmod-regmap
FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
AUTOLOAD:=$(call AutoProbe,c_can_platform)
$(call AddDepends/can)
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index ca529ff424..e702a3d9b3 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -160,6 +160,7 @@ define KernelPackage/fs-ext4
+kmod-crypto-hash
KCONFIG:= \
CONFIG_EXT4_FS \
+ CONFIG_EXT4_ENCRYPTION=n \
CONFIG_JBD2
FILES:= \
$(LINUX_DIR)/fs/ext4/ext4.ko \
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 77a8bff85a..90adc28126 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -13,7 +13,9 @@ WATCHDOG_DIR:=watchdog
define KernelPackage/6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=6LoWPAN shared code
- KCONFIG:=CONFIG_6LOWPAN
+ KCONFIG:= \
+ CONFIG_6LOWPAN \
+ CONFIG_6LOWPAN_NHC=n
FILES:=$(LINUX_DIR)/net/6lowpan/6lowpan.ko
AUTOLOAD:=$(call AutoProbe,6lowpan)
endef
@@ -40,14 +42,18 @@ define KernelPackage/bluetooth
CONFIG_BLUEZ_HIDP \
CONFIG_BT \
CONFIG_BT_BREDR=y \
+ CONFIG_BT_DEBUGFS=n \
CONFIG_BT_L2CAP=y \
CONFIG_BT_LE=y \
CONFIG_BT_SCO=y \
CONFIG_BT_RFCOMM \
CONFIG_BT_BNEP \
CONFIG_BT_HCIBTUSB \
+ CONFIG_BT_HCIBTUSB_BCM=n \
CONFIG_BT_HCIUSB \
CONFIG_BT_HCIUART \
+ CONFIG_BT_HCIUART_BCM=n \
+ CONFIG_BT_HCIUART_INTEL=n \
CONFIG_BT_HCIUART_H4 \
CONFIG_BT_HIDP \
CONFIG_HID_SUPPORT=y
@@ -59,6 +65,10 @@ define KernelPackage/bluetooth
$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
$(LINUX_DIR)/drivers/bluetooth/btusb.ko
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,4.1.0)),1)
+ FILES+= \
+ $(LINUX_DIR)/drivers/bluetooth/btintel.ko
+endif
AUTOLOAD:=$(call AutoProbe,bluetooth rfcomm bnep hidp hci_uart btusb)
endef