aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-06 04:52:51 +0000
committerJohn Crispin <john@openwrt.org>2014-10-06 04:52:51 +0000
commit9f08790436badf83c27ea7ca668869ae1ada3684 (patch)
tree075c3b1d858ef2d798b0c525b43ba05a0c13f9ca /package
parentfcbad42acd3e7333a7c0ade053d88c3d17cd0ecb (diff)
downloadupstream-9f08790436badf83c27ea7ca668869ae1ada3684.tar.gz
upstream-9f08790436badf83c27ea7ca668869ae1ada3684.tar.bz2
upstream-9f08790436badf83c27ea7ca668869ae1ada3684.zip
kernel: add rtc-ds1307 module support
Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 42791
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d56bb5076f..58aae3ce58 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -505,6 +505,24 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
+define KernelPackage/rtc-ds1307
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
+ $(call AddDepends/rtc)
+ DEPENDS+=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_DS1307
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1307.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-ds1307)
+endef
+
+define KernelPackage/rtc-ds1307/description
+ Kernel module for Dallas/Maxim DS1307/DS1337/DS1338/DS1340/DS1388/DS3231,
+ Epson RX-8025 and various other compatible RTC chips connected via I2C.
+endef
+
+$(eval $(call KernelPackage,rtc-ds1307))
+
+
define KernelPackage/rtc-ds1672
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1672 RTC support