aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 12:11:06 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-27 11:18:27 +0100
commit9ed108e98baae4ed7fbb6c8dd0ed4bd68dd4dc31 (patch)
tree1fc89cf29536e1d049a362711f324be3b4623ea2 /package
parent28af0f2fbd4fb66ecebdbbeca385054a2b105d3d (diff)
downloadupstream-9ed108e98baae4ed7fbb6c8dd0ed4bd68dd4dc31.tar.gz
upstream-9ed108e98baae4ed7fbb6c8dd0ed4bd68dd4dc31.tar.bz2
upstream-9ed108e98baae4ed7fbb6c8dd0ed4bd68dd4dc31.zip
kernel: update kmod-* packaging and dependencies for linux 4.9
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk7
-rw-r--r--package/kernel/linux/modules/hwmon.mk6
-rw-r--r--package/kernel/linux/modules/netsupport.mk2
-rw-r--r--package/kernel/linux/modules/other.mk16
-rw-r--r--package/kernel/linux/modules/usb.mk3
5 files changed, 25 insertions, 9 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index d9cb3dbce4..ca18a16058 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -124,9 +124,10 @@ define KernelPackage/crypto-iv
TITLE:=CryptoAPI initialization vectors
DEPENDS:=+kmod-crypto-manager +kmod-crypto-rng +kmod-crypto-wq
KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2
+ HIDDEN:=1
FILES:= \
- $(LINUX_DIR)/crypto/eseqiv.ko \
- $(LINUX_DIR)/crypto/chainiv.ko
+ $(LINUX_DIR)/crypto/eseqiv.ko@lt4.9 \
+ $(LINUX_DIR)/crypto/chainiv.ko@lt4.9
AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv)
$(call AddDepends/crypto)
endef
@@ -195,7 +196,7 @@ $(eval $(call KernelPackage,crypto-hw-padlock))
define KernelPackage/crypto-hw-ccp
TITLE:=AMD Cryptographic Coprocessor
- DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core
+ DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core +kmod-crypto-sha1 +kmod-crypto-sha256
KCONFIG:= \
CONFIG_CRYPTO_HW=y \
CONFIG_CRYPTO_DEV_CCP=y \
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 8fdf62446d..6223a37ab2 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -127,7 +127,7 @@ define KernelPackage/hwmon-lm63
KCONFIG:=CONFIG_SENSORS_LM63
FILES:=$(LINUX_DIR)/drivers/hwmon/lm63.ko
AUTOLOAD:=$(call AutoProbe,lm63)
- $(call AddDepends/hwmon,+kmod-i2c-core)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-regmap)
endef
define KernelPackage/hwmon-lm63/description
@@ -142,7 +142,7 @@ define KernelPackage/hwmon-lm75
KCONFIG:=CONFIG_SENSORS_LM75
FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.ko
AUTOLOAD:=$(call AutoProbe,lm75)
- $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
+ $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal +kmod-regmap)
endef
define KernelPackage/hwmon-lm75/description
@@ -318,7 +318,7 @@ define KernelPackage/hwmon-tmp102
KCONFIG:=CONFIG_SENSORS_TMP102
FILES:=$(LINUX_DIR)/drivers/hwmon/tmp102.ko
AUTOLOAD:=$(call AutoProbe,tmp102)
- $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
+ $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal +kmod-regmap)
endef
define KernelPackage/hwmon-tmp102/description
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 3d5e74327a..bed0828634 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -533,7 +533,7 @@ $(eval $(call KernelPackage,gre))
define KernelPackage/gre6
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=GRE support over IPV6
- DEPENDS:=@IPV6 +kmod-iptunnel +kmod-ip6-tunnel
+ DEPENDS:=@IPV6 +kmod-iptunnel +kmod-ip6-tunnel +kmod-gre
KCONFIG:=CONFIG_IPV6_GRE
FILES:=$(LINUX_DIR)/net/ipv6/ip6_gre.ko
AUTOLOAD:=$(call AutoLoad,39,ip6_gre)
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 370dc29671..18432de3c2 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -125,6 +125,19 @@ endef
$(eval $(call KernelPackage,dma-buf))
+define KernelPackage/nvmem
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Non Volatile Memory support
+ KCONFIG:=CONFIG_NVMEM
+ FILES:=$(LINUX_DIR)/drivers/nvmem/nvmem_core.ko@ge4.9
+endef
+
+define KernelPackage/nvmem/description
+ Support for NVMEM(Non Volatile Memory) devices like EEPROM, EFUSES, etc.
+endef
+
+$(eval $(call KernelPackage,nvmem))
+
define KernelPackage/eeprom-93cx6
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM 93CX6 support
@@ -144,7 +157,7 @@ define KernelPackage/eeprom-at24
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM AT24 support
KCONFIG:=CONFIG_EEPROM_AT24
- DEPENDS:=+kmod-i2c-core
+ DEPENDS:=+kmod-i2c-core +kmod-nvmem
FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at24.ko
AUTOLOAD:=$(call AutoProbe,at24)
endef
@@ -160,6 +173,7 @@ define KernelPackage/eeprom-at25
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM AT25 support
KCONFIG:=CONFIG_EEPROM_AT25
+ DEPENDS:=+kmod-nvmem
FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at25.ko
AUTOLOAD:=$(call AutoProbe,at25)
endef
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 6be8a2aa86..30534b882f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1386,7 +1386,8 @@ define KernelPackage/usb-chipidea
CONFIG_USB_CHIPIDEA_UDC=y \
CONFIG_USB_CHIPIDEA_DEBUG=y
FILES:= \
- $(LINUX_DIR)/drivers/extcon/extcon.ko \
+ $(LINUX_DIR)/drivers/extcon/extcon.ko@lt4.9 \
+ $(LINUX_DIR)/drivers/extcon/extcon-core.ko@ge4.9 \
$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko
AUTOLOAD:=$(call AutoLoad,51,ci_hdrc,0)
$(call AddDepends/usb)