aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-12-18 11:08:16 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-01-03 18:05:47 +0100
commit9d11726d6c9775e0c9c14848b3696b10212505ab (patch)
treeadcef9967ede24099f4cabc638b9719b663d036a /package
parentfd5f0606fd85b96be6b69a81cd671bb72eacb4b9 (diff)
downloadupstream-9d11726d6c9775e0c9c14848b3696b10212505ab.tar.gz
upstream-9d11726d6c9775e0c9c14848b3696b10212505ab.tar.bz2
upstream-9d11726d6c9775e0c9c14848b3696b10212505ab.zip
kernel: Fix rtc-ds1307 dependency on hwmon-core for 4.19
It seems, that since Linux 4.18-rc1 rtc-ds1307 depends on hwmon-core. commit 6b583a64fd1e019fd01626b46892ebf2361951c5 Author: Heiner Kallweit <hkallweit1@gmail.com> Date: Wed Sep 27 22:41:26 2017 +0200 rtc: ds1307: simplify hwmon config We don't have to define an extra config symbol, IS_REACHABLE does what we need. And having this config symbol just to save the few bytes of hwmon support on non-DS3231 chips isn't worth it IMO (especially as the symbol is set per default). While at it, use the same dependency check for `kmod-regmap` as well, so it's future proof as well. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index c521405040..89dbcd0d0a 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -476,7 +476,7 @@ define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
- DEPENDS:=+kmod-i2c-core +LINUX_4_14:kmod-regmap
+ DEPENDS:=+kmod-i2c-core +!(LINUX_3_18||LINUX_4_9):kmod-regmap +!(LINUX_3_18||LINUX_4_9):kmod-hwmon-core
KCONFIG:=CONFIG_RTC_DRV_DS1307 \
CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1307.ko