aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-22 17:19:29 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-24 09:40:46 +0100
commit9a1f441ac81c0c2b96ec813a645bae4fc8792bf5 (patch)
treebba2ef1aa8355b382ccba1fdb0f2cb8b8b3ae7bd /package
parent44447f6882098fc35fb0c2b579846aa3aea6c148 (diff)
downloadupstream-9a1f441ac81c0c2b96ec813a645bae4fc8792bf5.tar.gz
upstream-9a1f441ac81c0c2b96ec813a645bae4fc8792bf5.tar.bz2
upstream-9a1f441ac81c0c2b96ec813a645bae4fc8792bf5.zip
kirkwood: enable SoC drivers in the kernel config
Clean up packaged modules Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
-rw-r--r--package/kernel/linux/modules/i2c.mk2
-rw-r--r--package/kernel/linux/modules/other.mk23
3 files changed, 5 insertions, 22 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 0a88c3be12..ff19751398 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -665,7 +665,7 @@ $(eval $(call KernelPackage,crypto-xts))
define KernelPackage/crypto-mv-cesa
TITLE:=Marvell crypto engine
- DEPENDS:=+kmod-crypto-manager @TARGET_kirkwood||TARGET_orion
+ DEPENDS:=+kmod-crypto-manager @TARGET_orion
KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index e1c65d493e..c4767735b9 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -140,7 +140,7 @@ I2C_MV64XXX_MODULES:=\
define KernelPackage/i2c-mv64xxx
$(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
TITLE:=Orion Platform I2C interface support
- DEPENDS:=@TARGET_kirkwood||TARGET_orion +kmod-i2c-core
+ DEPENDS:=TARGET_orion +kmod-i2c-core
endef
define KernelPackage/i2c-mv64xxx/description
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 0c9696956d..923a087651 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -501,7 +501,7 @@ $(eval $(call KernelPackage,wdt-omap))
define KernelPackage/wdt-orion
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell Orion Watchdog timer
- DEPENDS:=@TARGET_orion||TARGET_kirkwood
+ DEPENDS:=@TARGET_orion
KCONFIG:=CONFIG_ORION_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
AUTOLOAD:=$(call AutoLoad,50,orion_wdt,1)
@@ -587,7 +587,7 @@ $(eval $(call KernelPackage,rtc-isl1208))
define KernelPackage/rtc-marvell
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell SoC built-in RTC support
- DEPENDS:=@RTC_SUPPORT @TARGET_kirkwood||TARGET_orion
+ DEPENDS:=@RTC_SUPPORT @TARGET_orion
KCONFIG:=CONFIG_RTC_DRV_MV \
CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
@@ -795,7 +795,7 @@ $(eval $(call KernelPackage,zram))
define KernelPackage/mvsdio
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell SDIO support
- DEPENDS:=@TARGET_orion||TARGET_kirkwood +kmod-mmc
+ DEPENDS:=@TARGET_orion +kmod-mmc
KCONFIG:=CONFIG_MMC_MVSDIO
FILES:=$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
AUTOLOAD:=$(call AutoProbe,mvsdio)
@@ -975,23 +975,6 @@ endef
$(eval $(call KernelPackage,thermal-imx))
-define KernelPackage/thermal-kirkwood
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Temperature sensor on Marvell Kirkwood SoCs
- DEPENDS:=@TARGET_kirkwood +kmod-thermal
- KCONFIG:=CONFIG_KIRKWOOD_THERMAL
- FILES:=$(LINUX_DIR)/drivers/thermal/kirkwood_thermal.ko
- AUTOLOAD:=$(call AutoProbe,kirkwood_thermal)
-endef
-
-define KernelPackage/thermal-kirkwood/description
- Support for the Kirkwood thermal sensor driver into the Linux thermal
- framework. Only kirkwood 88F6282 and 88F6283 have this sensor.
-endef
-
-$(eval $(call KernelPackage,thermal-kirkwood))
-
-
define KernelPackage/gpio-beeper
SUBMENU:=$(OTHER_MENU)
TITLE:=GPIO beeper support