aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-07-14 18:08:21 +0200
committerFelix Fietkau <nbd@nbd.name>2021-07-14 18:09:23 +0200
commit99a22d48f2003910f0968369b61b9131a8f53d80 (patch)
tree4ba6de0103e8d0cd61e4fee5bfd273060e96ce21 /package
parent890bf06cef20015e2cec0274c87a9a2232691b6b (diff)
downloadupstream-99a22d48f2003910f0968369b61b9131a8f53d80.tar.gz
upstream-99a22d48f2003910f0968369b61b9131a8f53d80.tar.bz2
upstream-99a22d48f2003910f0968369b61b9131a8f53d80.zip
mt76: update to the latest version
624c681ef0c6 mt76: mt7921: enable VHT BFee capability a27dfcb63ccf mt76: connac: fix UC entry is being overwritten 6b691e62470e mt76: connac: add mt76_connac_power_save_sched in mt76_connac_pm_unref b14365bea586 mt76: mt7921: wake the device before dumping power table 82af16bddfc0 mt76: mt7921: make mt7921_set_channel static b24598b1c1a9 mt76: connac: add mt76_connac_mcu_get_nic_capability utility routine 5954e3381ff9 mt76: testmode: move chip-specific stats dump before common stats fd5b612f9aa4 mt76: mt7915: fix rx fcs error count in testmode d9d26a294f7b mt76: connac: fix the maximum interval schedule scan can support ed39c882f388 mt76: reduce rx buffer size to 2048 60f3d3adbba6 mt76: move mt76_get_next_pkt_id in mt76.h 67ed4d902c84 mt76: connac: check band caps in mt76_connac_mcu_set_rate_txpower 23c6ec49c000 mt76: make mt76_update_survey() per phy 5ca602fb9455 mt76: mt7915: introduce mt7915_mcu_set_txbf() c13df42282e9 mt76: mt7915: improve MU stability dee7dcddcaa0 mt76: use SPDX header file comment style 6fbd47153b3d mt76: mt7915: fix IEEE80211_HE_PHY_CAP7_MAX_NC for station mode 1b97dd1762ca mt76: mt7921: fix sta_state incorrect implementation 1b89053b5a6f mt76: mt7921: improve code readability for mt7921_update_txs 126649816785 mt76: mt7921: limit txpower according to userlevel power a5163ac09be2 mt76: mt7921: introduce dedicated control for deep_sleep e47c04db4d7e mt76: mt7921: fix kernel warning when reset on vif is not sta 063d3611662c mt76: mt7921: fix the coredump is being truncated 12bf28feba7c mt76: fix iv and CCMP header insertion 949327e76ee4 mt76: disable TWT capabilities for the moment 3530254c1bc9 mt76: mt7921: enable HE BFee capability 599e35f5d9b8 mt76: sdio: do not run mt76_txq_schedule directly 3b6d30c28946 mt76: mt7663s: rely on pm reference counting 529d55a79088 mt76: mt7663s: rely on mt76_connac_pm_ref/mt76_connac_pm_unref in tx path ef44ff116ee2 mt76: mt7663s: enable runtime-pm 3a71e71a555e mt76: mt7615: set macwork timeout according to runtime-pm 925d96e443a4 mt76: mt7921: allow chip reset during device restart 63b114d84361 mt76: mt76x0e: fix device hang during suspend/resume 7f5ea5e2fd10 mt7915: check return code of sysfs_create_link ca64a36908b7 mt76: fix mt76_rates for the multiple devices f517116bf14c mt76: add mt76_default_basic_rate more devices can rely on 6c70b0100513 mt76: mt7921: fix mgmt frame using unexpected bitrate c00a9a6b52af mt76: mt7915: fix mgmt frame using unexpected bitrate 0e4089949565 mt76: mt7921: fix endianness in mt7921_mcu_tx_done_event 55f314120ef2 mt76: mt7921: avoid unnecessary spin_lock/spin_unlock in mt7921_mcu_tx_done_event 541cd3276488 mt76: mt7915: fix endianness warning in mt7915_mac_add_txs_skb 817761e87c4f mt76: mt7921: fix endianness warning in mt7921_update_txs b8eca74bbd7b mt76: mt7615: fix endianness warning in mt7615_mac_write_txwi 5e5e07f0def3 mt76: mt7915: fix potential overflow of eeprom page index abda4cded420 mt76: mt7915: fix info leak in mt7915_mcu_set_pre_cal() 535899f81a46 mt76: mt7915: fix calling mt76_wcid_alloc with incorrect parameter adfa1b9a3ca0 mt76: connac: fix mt76_connac_gtk_rekey_tlv usage 2a65b105ea4a mt76: mt7921: enable aspm by default c57158c82804 mt76: fix build error implicit enumeration conversion 41f607cab83c mt76: mt7921: fix survey-dump reporting 25b4f885a937 mt76: mt76x02: fix endianness warnings in mt76x02_mac.c e63fadb87fe1 mt76: mt7915: report HE MU radiotap 135ef3e9827a mt76: mt7915: adapt new firmware to update BA winsize for Rx session 7118eacb7ce4 mt76: mt7921: add .set_sar_specs support f1f6569da408 mt76: mt7915: fix an off-by-one bound check f7da39467965 mt76 mt7915: take RCU read lock when calling ieee80211_bss_get_elem() 87af8e5c72b1 mt76: mt7915: cleanup -Wunused-but-set-variable 8e2d383fbd92 mt76: mt7915: report tx rate directly from tx status ddce30977591 mt76: mt7915: remove mt7915_sta_stats 4ccd42029519 mt76: mt7921: introduce testmode support Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mt76/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 74d5950545..3969c13810 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-06-06
-PKG_SOURCE_VERSION:=22b690334c0f49b11534cc2e331c9d5e17c4a0bc
-PKG_MIRROR_HASH:=ff5e563935919d2e40c1e7254ef3bc06f7ecc5e69f8ddd12903e8f5de942d630
+PKG_SOURCE_DATE:=2021-07-14
+PKG_SOURCE_VERSION:=4ccd42029519d2b3d3b4e0abcd59928841845caf
+PKG_MIRROR_HASH:=26f721abd55587b331bae371dd41820796fcc27554c1be50e03572dccc82413e
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_USE_NINJA:=0