aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSvetoslav Neykov <svetoslav@neykov.name>2016-12-30 17:06:43 +0200
committerJohn Crispin <john@phrozen.org>2017-01-20 00:37:01 +0100
commit97b52593bcf928520aa5a294e3eb16042766d2e0 (patch)
treec6acb2571b968099cb7658b8613071e167accdfb /package
parentcf79e393f9550dd00e1926168f47d026e3cf72ee (diff)
downloadupstream-97b52593bcf928520aa5a294e3eb16042766d2e0.tar.gz
upstream-97b52593bcf928520aa5a294e3eb16042766d2e0.tar.bz2
upstream-97b52593bcf928520aa5a294e3eb16042766d2e0.zip
ar71xx: Chipidea USB device support
Changes the platform to use the Chipidea driver instead of the generic USB host driver which has support for both host and device modes (selected on boot). The changes in 930-chipidea-pullup.patch are already in mainline. I'll upstream 920-usb-chipidea-AR933x-platform-support.patch once I can test the changes with a newer kernel. Signed-off-by: Svetoslav Neykov <svetoslav@neykov.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 4fe17f56ec..2e449318ba 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1375,6 +1375,29 @@ endef
$(eval $(call KernelPackage,usbip-server))
+define KernelPackage/usb-chipidea
+ TITLE:=Host and device support for Chipidea controllers
+ DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget
+ KCONFIG:= \
+ CONFIG_NOP_USB_XCEIV=y \
+ CONFIG_EXTCON \
+ CONFIG_USB_CHIPIDEA \
+ CONFIG_USB_CHIPIDEA_HOST=y \
+ CONFIG_USB_CHIPIDEA_UDC=y \
+ CONFIG_USB_CHIPIDEA_DEBUG=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/extcon/extcon.ko \
+ $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko
+ AUTOLOAD:=$(call AutoLoad,51,ci_hdrc,0)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-chipidea/description
+ Kernel support for USB Chipidea controllers
+endef
+
+$(eval $(call KernelPackage,usb-chipidea))
+
define KernelPackage/usbmon
TITLE:=USB traffic monitor
KCONFIG:=CONFIG_USB_MON