aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-02-03 21:15:42 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-02-24 21:35:31 +0800
commit8d8ef24eebdcef426fe9fa3ea7bddf82e833499e (patch)
tree0bc3374e83071ca96fc51d370e91bdd37ca30eb4 /package
parent3e41afda5628b235742b8cec00313e5b1c00bb5c (diff)
downloadupstream-8d8ef24eebdcef426fe9fa3ea7bddf82e833499e.tar.gz
upstream-8d8ef24eebdcef426fe9fa3ea7bddf82e833499e.tar.bz2
upstream-8d8ef24eebdcef426fe9fa3ea7bddf82e833499e.zip
mac80211: hwsim: select DRIVER_11AC_SUPPORT and DRIVER_11W_SUPPORT
This is required for default wireless configuration of malta target to work out of the box again. Fixes "77ece30e: hostapd: Add ability to specify that that wireless driver supports 802.11ac" Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 5a591e4b83..578014ffaa 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1022,7 +1022,7 @@ endef
define KernelPackage/mac80211-hwsim
$(call KernelPackage/mac80211/Default)
TITLE:=mac80211 HW simulation device
- DEPENDS+= +kmod-mac80211 +@DRIVER_11N_SUPPORT
+ DEPENDS+= +kmod-mac80211 +@DRIVER_11AC_SUPPORT +@DRIVER_11N_SUPPORT +@DRIVER_11W_SUPPORT
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/mac80211_hwsim.ko
AUTOLOAD:=$(call AutoProbe,mac80211_hwsim)
endef