aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-06-11 11:17:52 +0200
committerHans Dedecker <dedeckeh@gmail.com>2018-06-11 11:41:26 +0200
commit8d60f6ee407373349173fac08985baefe83b5f5c (patch)
treef9bf103b6f0abac5d45ca3c0ca0450b8d1c105cb /package
parent83483ba787e5c972099da1e983e95f396961c7f2 (diff)
downloadupstream-8d60f6ee407373349173fac08985baefe83b5f5c.tar.gz
upstream-8d60f6ee407373349173fac08985baefe83b5f5c.tar.bz2
upstream-8d60f6ee407373349173fac08985baefe83b5f5c.zip
dnsmasq: fix confdir option processing (FS#1572)
Fix condir option processing allowing to use the format "<directory>[,<file-extension>......]," as documented on the dnsmasq man page which previously resulted into bogus dir being created. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/dnsmasq/Makefile2
-rw-r--r--package/network/services/dnsmasq/files/dnsmasq.init3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 7fa61ad04f..bb68a67296 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.80test2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/test-releases
diff --git a/package/network/services/dnsmasq/files/dnsmasq.init b/package/network/services/dnsmasq/files/dnsmasq.init
index 2c71a777c3..4906df9ce4 100644
--- a/package/network/services/dnsmasq/files/dnsmasq.init
+++ b/package/network/services/dnsmasq/files/dnsmasq.init
@@ -941,8 +941,9 @@ dnsmasq_start()
xappend "--addn-hosts=$(dirname $HOSTFILE)"
config_get dnsmasqconfdir "$cfg" confdir "/tmp/dnsmasq.d"
- [ ! -d "$dnsmasqconfdir" ] && mkdir -p $dnsmasqconfdir
xappend "--conf-dir=$dnsmasqconfdir"
+ dnsmasqconfdir="${dnsmasqconfdir%%,*}"
+ [ ! -d "$dnsmasqconfdir" ] && mkdir -p $dnsmasqconfdir
xappend "--user=dnsmasq"
xappend "--group=dnsmasq"
echo >> $CONFIGFILE_TMP