aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-06 15:09:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-06 15:09:43 +0000
commit82b3e879d4dab55ad16fa2c1872b43b3684f8d62 (patch)
tree8846975e15fa83fefd8ac8de4cfc9f81b3648c65 /package
parent75657ff8a94edc9fa3b0e35404dd6363d04003ee (diff)
downloadupstream-82b3e879d4dab55ad16fa2c1872b43b3684f8d62.tar.gz
upstream-82b3e879d4dab55ad16fa2c1872b43b3684f8d62.tar.bz2
upstream-82b3e879d4dab55ad16fa2c1872b43b3684f8d62.zip
kernel: add a module for the isl1208 rtc
SVN-Revision: 35022
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 1c8a3dcfef..ddaef8d901 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -539,6 +539,23 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
+define KernelPackage/rtc-isl1208
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Intersil ISL1208 RTC support
+ $(call AddDepends/rtc)
+ DEPENDS+=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_ISL1208
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-isl1208.ko
+ AUTOLOAD:=$(call AutoLoad,60,rtc-isl1208)
+endef
+
+define KernelPackage/rtc-isl1208/description
+ Kernel module for Intersil ISL1208 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-isl1208))
+
+
define KernelPackage/rtc-marvell
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell SoC built-in RTC support