aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2017-10-14 17:57:19 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-15 00:24:22 +0200
commit81e28be824b397f7b6a5a682ee135549dd874125 (patch)
treeef6cc3131a9181f35fa88694b4fdbf41f9c8418d /package
parente4b6900fd60e43ba0527172c30290a69958b7f73 (diff)
downloadupstream-81e28be824b397f7b6a5a682ee135549dd874125.tar.gz
upstream-81e28be824b397f7b6a5a682ee135549dd874125.tar.bz2
upstream-81e28be824b397f7b6a5a682ee135549dd874125.zip
kernel: kmod-macsec module for 4.9
MACsec/IEEE 802.1AE is useful to secure communication to and from endpoints at Layer 2. Starting with 4.6, the linux kernel provides a universal macsec driver for authentication and encryption of traffic in a LAN, typically with GCM-AES-128, and optional replay protection. http://standards.ieee.org/getieee802/download/802.1AE-2006.pdf Note: LEDE can utilize MACsec with a static connectivity association key (static PSK) with the ip-full package installed. <http://man7.org/linux/man-pages/man8/ip-macsec.8.html> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netsupport.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 6c9b03be1d..e4740428af 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1009,3 +1009,18 @@ define KernelPackage/mdio/description
endef
$(eval $(call KernelPackage,mdio))
+
+define KernelPackage/macsec
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=IEEE 802.1AE MAC-level encryption (MAC)
+ DEPENDS:=+kmod-crypto-gcm @!LINUX_3_18 @!LINUX_4_1 @!LINUX_4_4
+ KCONFIG:=CONFIG_MACSEC
+ FILES:=$(LINUX_DIR)/drivers/net/macsec.ko
+ AUTOLOAD:=$(call AutoLoad,13,macsec)
+endef
+
+define KernelPackage/macsec/description
+ MACsec is an encryption standard for Ethernet.
+endef
+
+$(eval $(call KernelPackage,macsec))