aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2020-04-21 02:29:51 -0600
committerDaniel Golle <daniel@makrotopia.org>2020-10-30 00:39:09 +0000
commit7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b (patch)
tree6d03bb66da66065e3458d2986fd913c0065d0807 /package
parentc3a4cddaaf453b9387e0ce3c16c06376d8adde28 (diff)
downloadupstream-7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b.tar.gz
upstream-7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b.tar.bz2
upstream-7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b.zip
kmod-nft-reject: Fix for "nft_reject_ipv4.ko missing" warning
Seeing the following: ERROR: module '/home/philipp/lede/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.33/net/ipv4/netfilter/nft_reject_ipv4.ko' is missing. modules/netfilter.mk:1068: recipe for target '/home/philipp/lede/bin/targets/x86/64/packages/kmod-nft-core_5.4.33-1_x86_64.ipk' failed make[3]: *** [/home/philipp/lede/bin/targets/x86/64/packages/kmod-nft-core_5.4.33-1_x86_64.ipk] Error 1 Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netfilter.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 83bb59be83..9f9798179f 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1058,6 +1058,9 @@ define KernelPackage/nft-core
KCONFIG:= \
CONFIG_NFT_COMPAT=n \
CONFIG_NFT_QUEUE=n \
+ CONFIG_NFT_REJECT_INET \
+ CONFIG_NFT_REJECT_IPV4 \
+ CONFIG_NFT_REJECT_IPV6 \
$(KCONFIG_NFT_CORE)
endef