aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAndy Strohman <andrew@andrewstrohman.com>2016-12-18 11:06:06 -0800
committerFelix Fietkau <nbd@nbd.name>2016-12-20 16:24:22 +0100
commit7acb7dc3db823687b0c05a0b0ee31e05267ff551 (patch)
tree691e923ac0f68a008932f3634888c310aaf55746 /package
parent4344eb62bfdbd4579cfadbee887dde051ad10a3a (diff)
downloadupstream-7acb7dc3db823687b0c05a0b0ee31e05267ff551.tar.gz
upstream-7acb7dc3db823687b0c05a0b0ee31e05267ff551.tar.bz2
upstream-7acb7dc3db823687b0c05a0b0ee31e05267ff551.zip
ath10k-ct: Enable DFS when "Enable DFS support" is set for kmod-ath
This allows users of this package to configure DFS channels. It mimics the behaviour of the ath10k module included in package mac80211 Signed-off-by: Andy Strohman <andrew@andrewstrohman.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/ath10k-ct/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index c5e5045124..97f284efbf 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -61,6 +61,10 @@ ifdef CONFIG_PACKAGE_ATH_DEBUG
NOSTDINC_FLAGS += -DCONFIG_ATH10K_DEBUG
endif
+ifdef CONFIG_PACKAGE_ATH_DFS
+ NOSTDINC_FLAGS += -DCONFIG_ATH10K_DFS_CERTIFIED
+endif
+
define Build/Configure
cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
endef