aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-07-27 21:04:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-07-27 21:04:49 +0000
commit7a5f143f64aa4b4016c29992b0eaa956da86eef6 (patch)
tree25e66289c22991c0471e4265be853234240c7a01 /package
parent65899cfa4946f945d1a91eab21b73f7534d5baf8 (diff)
downloadupstream-7a5f143f64aa4b4016c29992b0eaa956da86eef6.tar.gz
upstream-7a5f143f64aa4b4016c29992b0eaa956da86eef6.tar.bz2
upstream-7a5f143f64aa4b4016c29992b0eaa956da86eef6.zip
kmod-ipsec: fix a compile error with some configurations. since CONFIG_XFRM_IPCOMP is not selectable on its own (no prompt), always select CONFIG_INET_IPCOMP along with it, to make sure that it gets enabled
SVN-Revision: 22402
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netsupport.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index bdd0f7516e..4f024f2be0 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -181,6 +181,7 @@ define KernelPackage/ipsec
KCONFIG:= \
CONFIG_NET_KEY \
CONFIG_XFRM_USER \
+ CONFIG_INET_IPCOMP \
CONFIG_XFRM_IPCOMP
FILES:=$(foreach mod,$(IPSEC-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoLoad,30,$(notdir $(IPSEC-m)))