aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-07-18 18:59:12 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-07-18 18:59:12 +0000
commit7882a1856a238f32b5c16f93ffc2262bd5116c59 (patch)
tree64b07fc232562a8cdced87b73c4a9fb074b8eaf3 /package
parent1dd824a358ca3f33bbc3f53ef021b638eb8d0d3a (diff)
downloadupstream-7882a1856a238f32b5c16f93ffc2262bd5116c59.tar.gz
upstream-7882a1856a238f32b5c16f93ffc2262bd5116c59.tar.bz2
upstream-7882a1856a238f32b5c16f93ffc2262bd5116c59.zip
package/kernel: modularize ixp4xx_eth driver & marvel 88E6060 phy support
SVN-Revision: 22283
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netdevices.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index d9e9a3c7ed..f4f564a8cf 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -36,6 +36,21 @@ endef
$(eval $(call KernelPackage,swconfig))
+define KernelPackage/mvswitch
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Marvell 88E6060 switch support
+ DEPENDS:=+kmod-swconfig
+ KCONFIG:=CONFIG_MVSWITCH_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/mvswitch.ko
+ AUTOLOAD:=$(call AutoLoad,41,mvswitch)
+endef
+
+define KernelPackage/mvswitch/description
+ Marvell 88E6060 switch support
+endef
+
+$(eval $(call KernelPackage,mvswitch))
+
define KernelPackage/switch-ip175c
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=IC+ IP175C/IP178C switch support
@@ -155,6 +170,20 @@ endef
$(eval $(call KernelPackage,via-velocity))
+define KernelPackage/ixp4xx-eth
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=IXP4xxt Ethernet Adapter kernel support
+ DEPENDS:=@TARGET_ixp4xx
+ KCONFIG:=CONFIG_IXP4XX_ETH
+ FILES:=$(LINUX_DIR)/drivers/net/arm/ixp4xx_eth.ko
+ AUTOLOAD:=$(call AutoLoad,50,ixp4xx_eth)
+endef
+
+define KernelPackage/ixp4xx-eth/description
+ Kernel modules for Intel IXP4xx Ethernet chipsets.
+endef
+
+$(eval $(call KernelPackage,ixp4xx-eth))
define KernelPackage/8139too
SUBMENU:=$(NETWORK_DEVICES_MENU)