aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:51 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:51 +0000
commit76b79b5635abd16bd466e7add3eaf98be9b7d1a3 (patch)
tree30749f233c5af766046a59934a358c1f520fd554 /package
parentca4b30daed8dde75631c3856191651a09f1b79a2 (diff)
downloadupstream-76b79b5635abd16bd466e7add3eaf98be9b7d1a3.tar.gz
upstream-76b79b5635abd16bd466e7add3eaf98be9b7d1a3.tar.bz2
upstream-76b79b5635abd16bd466e7add3eaf98be9b7d1a3.zip
kernel/gpio_keys: load module on pre-init
fix rescue mode on wdr4900 Signed-off-by: Alexander Couzens <lynxis@fe80.eu> Backport of r48793 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48851 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/input.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 86ff33cb26..eed9aa2680 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -75,7 +75,7 @@ define KernelPackage/input-gpio-keys
CONFIG_KEYBOARD_GPIO \
CONFIG_INPUT_KEYBOARD=y
FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
- AUTOLOAD:=$(call AutoProbe,gpio_keys)
+ AUTOLOAD:=$(call AutoProbe,gpio_keys,1)
endef
define KernelPackage/input-gpio-keys/description