aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2016-04-27 11:13:58 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-28 13:47:48 +0200
commit7545c1d96b9791d285b71cf8f142326160faa940 (patch)
treebf84a488fbd7d4fa7a29e72c1c7b2f722f966380 /package
parenta83f049b5be3396deaecaafa3b7adb447a1d1336 (diff)
downloadupstream-7545c1d96b9791d285b71cf8f142326160faa940.tar.gz
upstream-7545c1d96b9791d285b71cf8f142326160faa940.tar.bz2
upstream-7545c1d96b9791d285b71cf8f142326160faa940.zip
dropbear: Make utmp and putuline support configurable via seperate config options
Utmp support tracks who is currenlty logged in by logging info to the file /var/run/utmp (supported by busybox) Putuline support will use the utmp structure to write to the utmp file Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/dropbear/Config.in15
-rw-r--r--package/network/services/dropbear/Makefile5
2 files changed, 17 insertions, 3 deletions
diff --git a/package/network/services/dropbear/Config.in b/package/network/services/dropbear/Config.in
index 3316c84e9e..7c2edd79f2 100644
--- a/package/network/services/dropbear/Config.in
+++ b/package/network/services/dropbear/Config.in
@@ -32,4 +32,19 @@ config DROPBEAR_ECC
Increases binary size by about 23 kB (MIPS).
+config DROPBEAR_UTMP
+ bool "Utmp support"
+ default n
+ depends on BUSYBOX_CONFIG_FEATURE_UTMP
+ help
+ This enables dropbear utmp support, the file /var/run/utmp is used to
+ track who is currently logged in.
+
+config DROPBEAR_PUTUTLINE
+ bool "Pututline support"
+ default n
+ depends on DROPBEAR_UTMP
+ help
+ Dropbear will use pututline() to write the utmp structure into the utmp file.
+
endmenu
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 39ab04bb54..593e0a81bf 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -68,12 +68,11 @@ CONFIGURE_ARGS += \
--enable-syslog \
$(if $(CONFIG_SHADOW_PASSWORDS),,--disable-shadow) \
--disable-lastlog \
- --disable-utmp \
- --disable-utmpx \
+ $(if $(CONFIG_DROPBEAR_UTMP),,--disable-utmp) \
--disable-wtmp \
--disable-wtmpx \
--disable-loginfunc \
- --disable-pututline \
+ $(if $(CONFIG_DROPBEAR_PUTUTLINE),,--disable-pututline) \
--disable-pututxline \
--disable-zlib \
--enable-bundled-libtom