aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-08-19 00:59:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-08-19 00:59:05 +0000
commit73c9032e871770ed545e474b25367397f1671e90 (patch)
tree0a506a17cc37eb546d75f9ee6c5109ec1f4adfd7 /package
parent0826570bc45aef54c5bf002b9900617edb0c78b2 (diff)
downloadupstream-73c9032e871770ed545e474b25367397f1671e90.tar.gz
upstream-73c9032e871770ed545e474b25367397f1671e90.tar.bz2
upstream-73c9032e871770ed545e474b25367397f1671e90.zip
6in4: bypass uci state when reading local IPv4 addr, specify TTL during tunnel creation (#7769)
SVN-Revision: 22708
Diffstat (limited to 'package')
-rw-r--r--package/6in4/Makefile2
-rwxr-xr-xpackage/6in4/files/6in4.sh6
2 files changed, 3 insertions, 5 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index 289d28ee3f..c56b9c57ce 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=4
+PKG_VERSION:=5
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6in4/files/6in4.sh b/package/6in4/files/6in4.sh
index a119138d0f..bea2e82ea3 100755
--- a/package/6in4/files/6in4.sh
+++ b/package/6in4/files/6in4.sh
@@ -28,8 +28,7 @@ setup_interface_6in4() {
local cfg="$2"
local link="6in4-$cfg"
- local local4
- config_get local4 "$cfg" ipaddr
+ local local4=$(uci_get network "$cfg" local4)
local remote4
config_get remote4 "$cfg" peeraddr
@@ -62,10 +61,9 @@ setup_interface_6in4() {
uci_set_state network "$cfg" ifname $link
uci_set_state network "$cfg" auto 0
- ip tunnel add $link mode sit remote $remote4 local $local4 ttl 255
+ ip tunnel add $link mode sit remote $remote4 local $local4 ttl ${ttl:-64}
ip link set $link up
ip link set mtu ${mtu:-1280} dev $link
- ip tunnel change $link ttl ${ttl:-64}
ip addr add $local6 dev $link
uci_set_state network "$cfg" ipaddr $local4