aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-05-15 21:56:27 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-27 22:05:14 +0200
commit728afd14fa385a90c6eede3bebfdf4d77938ccc2 (patch)
tree1cb56e1d607602db56d2406665617435bb1aee11 /package
parent9466152ea84e3447b7757f9e18b15c7b00b022a5 (diff)
downloadupstream-728afd14fa385a90c6eede3bebfdf4d77938ccc2.tar.gz
upstream-728afd14fa385a90c6eede3bebfdf4d77938ccc2.tar.bz2
upstream-728afd14fa385a90c6eede3bebfdf4d77938ccc2.zip
linux-firmware: move firmware file for mt7601u
The firmware file for mt7601u (MediaTek MT7601U Wireless MACs) has been moved to the mediatek/ folder by commit 8451c2b1 mt76xx: Move the old Mediatek WiFi firmware to mediatek Address this by updating the location of the firmware file in our linux-firmware Makefile generating the mt7601u-firmware package. All other MediaTek Wi-Fi firmware files are supplied by OpenWrt's own repository rather than being taken from linux-firmware. Fixes: d53fe5d9ce ("linux-firmware: update to 20230515") Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit d26ecbcf95e2c2ecf5380fdee733c6b46276e265)
Diffstat (limited to 'package')
-rw-r--r--package/firmware/linux-firmware/mediatek.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/firmware/linux-firmware/mediatek.mk b/package/firmware/linux-firmware/mediatek.mk
index 18677bc748..77f3365f27 100644
--- a/package/firmware/linux-firmware/mediatek.mk
+++ b/package/firmware/linux-firmware/mediatek.mk
@@ -1,9 +1,9 @@
Package/mt7601u-firmware = $(call Package/firmware-default,MediaTek MT7601U firmware)
define Package/mt7601u-firmware/install
- $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DIR) $(1)/lib/firmware/mediatek
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/mt7601u.bin \
- $(1)/lib/firmware
+ $(PKG_BUILD_DIR)/mediatek/mt7601u.bin \
+ $(1)/lib/firmware/mediatek
endef
$(eval $(call BuildPackage,mt7601u-firmware))