aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-07 07:22:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-07 07:22:11 +0000
commit7138c77f5aa347ed310c28df05caec19a6425649 (patch)
tree49a0b431ccf83da372dc695927c8ea98c0ff5884 /package
parentbd87d11e58637a9d3a6db9340213fa2bf05caa06 (diff)
downloadupstream-7138c77f5aa347ed310c28df05caec19a6425649.tar.gz
upstream-7138c77f5aa347ed310c28df05caec19a6425649.tar.bz2
upstream-7138c77f5aa347ed310c28df05caec19a6425649.zip
kernel: remove NAND flash related kmod-* packages
They are useless, as the platform already selects the right options for NAND support. The main reason for removing them is the fact that it makes kernel configs more annoying to maintain on platforms that provide NAND drivers but disable them (e.g. ramips) Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45919
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk35
1 files changed, 0 insertions, 35 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 955c140d96..6ca9f5e140 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -638,7 +638,6 @@ define KernelPackage/mtdtests
SUBMENU:=$(OTHER_MENU)
TITLE:=MTD subsystem tests
KCONFIG:=CONFIG_MTD_TESTS
- DEPENDS:=+kmod-nand
FILES:=\
$(LINUX_DIR)/drivers/mtd/tests/mtd_nandecctest.ko \
$(LINUX_DIR)/drivers/mtd/tests/mtd_oobtest.ko \
@@ -657,40 +656,6 @@ endef
$(eval $(call KernelPackage,mtdtests))
-define KernelPackage/nand
- SUBMENU:=$(OTHER_MENU)
- TITLE:=NAND flash support
- KCONFIG:=CONFIG_MTD_NAND \
- CONFIG_MTD_NAND_IDS \
- CONFIG_MTD_NAND_ECC
- FILES:= \
- $(LINUX_DIR)/drivers/mtd/nand/nand_ids.ko \
- $(LINUX_DIR)/drivers/mtd/nand/nand_ecc.ko \
- $(LINUX_DIR)/drivers/mtd/nand/nand.ko
- AUTOLOAD:=$(call AutoLoad,20,nand_ids nand_ecc nand)
-endef
-
-define KernelPackage/nand/description
- Kernel module for NAND support
-endef
-
-$(eval $(call KernelPackage,nand))
-
-
-define KernelPackage/nandsim
- SUBMENU:=$(OTHER_MENU)
- TITLE:=NAND simulator
- DEPENDS:=+kmod-nand
- KCONFIG:=CONFIG_MTD_NAND_NANDSIM
- FILES:=$(LINUX_DIR)/drivers/mtd/nand/nandsim.ko
-endef
-
-define KernelPackage/nandsim/description
- Kernel module for NAND flash simulation.
-endef
-
-$(eval $(call KernelPackage,nandsim))
-
define KernelPackage/serial-8250
SUBMENU:=$(OTHER_MENU)
TITLE:=8250 UARTs