aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-12-19 23:23:34 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-12-19 23:23:34 +0000
commit6e7d48b1ead4c21e215437fb2d82748186589dc2 (patch)
treefa3c7c4cf86c2b79a1807bf779dd31e1f8706604 /package
parenteb3bd41114d0fc90cbb979ae6e464eeaa5b7b0f2 (diff)
downloadupstream-6e7d48b1ead4c21e215437fb2d82748186589dc2.tar.gz
upstream-6e7d48b1ead4c21e215437fb2d82748186589dc2.tar.bz2
upstream-6e7d48b1ead4c21e215437fb2d82748186589dc2.zip
mac80211: deactivate mac80211 tracing
Activating tracing on kernel <= 2.6.32 causes build errors. SVN-Revision: 29572
Diffstat (limited to 'package')
-rw-r--r--package/mac80211/patches/070-deactivate_mac80211_tracing.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/mac80211/patches/070-deactivate_mac80211_tracing.patch b/package/mac80211/patches/070-deactivate_mac80211_tracing.patch
new file mode 100644
index 0000000000..feff5eb9a0
--- /dev/null
+++ b/package/mac80211/patches/070-deactivate_mac80211_tracing.patch
@@ -0,0 +1,44 @@
+Do not activate the mac80211 tracing by default as it does not work with
+kernel <= 2.6.32. Compat also includes include/trace/define_trace.h over
+include/trace/events/module.h which makes this not compiling any more.
+
+--- a/net/mac80211/Makefile
++++ b/net/mac80211/Makefile
+@@ -24,8 +24,7 @@ mac80211-y := \
+ util.o \
+ wme.o \
+ event.o \
+- chan.o \
+- driver-trace.o
++ chan.o
+
+ mac80211-$(CONFIG_MAC80211_LEDS) += led.o
+ mac80211-$(CONFIG_MAC80211_DEBUGFS) += \
+@@ -42,6 +41,7 @@ mac80211-$(CONFIG_MAC80211_MESH) += \
+
+ mac80211-$(CONFIG_PM) += pm.o
+
++mac80211-$(CONFIG_MAC80211_DRIVER_API_TRACER) += driver-trace.o
+ CFLAGS_driver-trace.o := -I$(src)
+
+ # objects for PID algorithm
+--- a/net/mac80211/driver-trace.h
++++ b/net/mac80211/driver-trace.h
+@@ -5,6 +5,17 @@
+ #include <net/mac80211.h>
+ #include "ieee80211_i.h"
+
++#if !defined(CONFIG_MAC80211_DRIVER_API_TRACER) || defined(__CHECKER__)
++#undef TRACE_EVENT
++#define TRACE_EVENT(name, proto, ...) \
++static inline void trace_ ## name(proto) {}
++#undef DECLARE_EVENT_CLASS
++#define DECLARE_EVENT_CLASS(...)
++#undef DEFINE_EVENT
++#define DEFINE_EVENT(evt_class, name, proto, ...) \
++static inline void trace_ ## name(proto) {}
++#endif
++
+ #undef TRACE_SYSTEM
+ #define TRACE_SYSTEM mac80211
+