aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-19 22:46:24 +0000
committerMike Baker <mbm@openwrt.org>2006-05-19 22:46:24 +0000
commit6ae20c689a562e133596a018fa65b771fde67c5b (patch)
tree46f55bf4c2d3e1cfeb45070ddf91640bdacd87d7 /package
parentcd466375e1cff138808173308b7d3d9446fc7303 (diff)
downloadupstream-6ae20c689a562e133596a018fa65b771fde67c5b.tar.gz
upstream-6ae20c689a562e133596a018fa65b771fde67c5b.tar.bz2
upstream-6ae20c689a562e133596a018fa65b771fde67c5b.zip
clean up menu configuration
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3801 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile6
-rw-r--r--package/rules.mk8
2 files changed, 12 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 23dcc1cf8d..ff23ee7dd8 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -15,14 +15,18 @@ PKG_CAT:=bzcat
include $(TOPDIR)/package/rules.mk
define Package/busybox
-CONFIGFILE:=config/Config.in
SECTION:=base
CATEGORY:=Base system
+MENU:=1
DEFAULT:=y
TITLE:=Core utilities for embedded Linux
DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
It slices, it dices, it makes Julian Fries.
URL:=http://busybox.net/
+CONFIG:=menu "Configuration" \\\
+ depends on PACKAGE_busybox \\\
+source "package/busybox/config/Config.in" \\\
+endmenu
endef
define Build/Configure
diff --git a/package/rules.mk b/package/rules.mk
index e8417c3a5f..99e4a846a5 100644
--- a/package/rules.mk
+++ b/package/rules.mk
@@ -116,6 +116,12 @@ define BuildPackage
DUMPINFO += \
echo "@@";
+ ifneq ($(CONFIG),)
+ DUMPINFO += \
+ echo "Config: $(CONFIG)" | sed -e 's,\\,\n,g'; \
+ echo "@@";
+ endif
+
$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
mkdir -p $$(IDIR_$(1))/CONTROL
echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
@@ -222,7 +228,7 @@ endef
ifneq ($(DUMP),)
dumpinfo: FORCE
- $(DUMPINFO)
+ @$(DUMPINFO)
else
$(PACKAGE_DIR):