aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2009-03-07 14:03:12 +0000
committerHauke Mehrtens <hauke@openwrt.org>2009-03-07 14:03:12 +0000
commit69a82afb672610d184319158475ca9515a3770ef (patch)
treea4ec6442dc762b9a27e179675914a8490de9086c /package
parent3df012038c6bc218c3f482c9bd6a824ad3003911 (diff)
downloadupstream-69a82afb672610d184319158475ca9515a3770ef.tar.gz
upstream-69a82afb672610d184319158475ca9515a3770ef.tar.bz2
upstream-69a82afb672610d184319158475ca9515a3770ef.zip
[kernel] aec62xx is working with kernel 2.6.28 agagin.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14773 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/block.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 2c720eba10..a7b6ef2415 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -135,7 +135,7 @@ $(eval $(call KernelPackage,ata-via-sata))
define KernelPackage/ide-core
SUBMENU:=$(BLOCK_MENU)
TITLE:=IDE (ATA/ATAPI) device support
- DEPENDS:=@PCI_SUPPORT @LINUX_2_6_28:BROKEN
+ DEPENDS:=@PCI_SUPPORT
KCONFIG:= \
CONFIG_IDE \
CONFIG_IDE_GENERIC \
@@ -183,7 +183,11 @@ define KernelPackage/ide-aec62xx
TITLE:=Acard AEC62xx IDE driver
DEPENDS:=@PCI_SUPPORT +kmod-ide-core
KCONFIG:=CONFIG_BLK_DEV_AEC62XX
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),1)
+ FILES:=$(LINUX_DIR)/drivers/ide/aec62xx.$(LINUX_KMOD_SUFFIX)
+else
FILES:=$(LINUX_DIR)/drivers/ide/pci/aec62xx.$(LINUX_KMOD_SUFFIX)
+endif
AUTOLOAD:=$(call AutoLoad,30,aec62xx)
endef