aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-15 03:52:13 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-15 03:52:13 +0000
commit698aa8f707f04f64fb5197ba616347636370c385 (patch)
treece0ce89be6b4f2f2319bc4ef238c35f45f2f750d /package
parentb97629f51b14dc8abdadf8d1d52ff1393e72c3e8 (diff)
downloadupstream-698aa8f707f04f64fb5197ba616347636370c385.tar.gz
upstream-698aa8f707f04f64fb5197ba616347636370c385.tar.bz2
upstream-698aa8f707f04f64fb5197ba616347636370c385.zip
[PATCH] Support for Solos PCI ADSL2+ modem
This driver is used by Traverse Technologies' Geos ADSL2+ x86 router: http://www.traverse.com.au/productview.php?product_id=117 Signed-off-by: Nathan Williams <nathan@traverse.com.au> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23070 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netdevices.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index 69ec517adb..aaee3acce8 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -484,3 +484,20 @@ define KernelPackage/tulip/description
endef
$(eval $(call KernelPackage,tulip))
+
+
+define KernelPackage/solos-pci
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Solos ADSL2+ multiport modem
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_ATM_SOLOS
+ FILES:=$(LINUX_DIR)/drivers/atm/solos-pci.ko
+ AUTOLOAD:=$(call AutoLoad,50,solos-pci)
+endef
+
+define KernelPackage/solos-pci/description
+ Kernel module for Traverse Technologies' Solos PCI cards
+ and Geos ADSL2+ x86 motherboard.
+endef
+
+$(eval $(call KernelPackage,solos-pci))