aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2020-11-03 20:08:03 +0000
committerDaniel Golle <daniel@makrotopia.org>2020-11-08 20:25:59 +0000
commit682843adadd753f174c4d7a8b1e487f7ee91e53a (patch)
treef31635a913a0ea1110d527869552764c3ed7d00a /package
parent93adba459794c0bb32373ab5504992199b5c5314 (diff)
downloadupstream-682843adadd753f174c4d7a8b1e487f7ee91e53a.tar.gz
upstream-682843adadd753f174c4d7a8b1e487f7ee91e53a.tar.bz2
upstream-682843adadd753f174c4d7a8b1e487f7ee91e53a.zip
hostapd: add a hostapd-basic-wolfssl variant
If only AP mode is needed, this is currently the most space-efficient way to provide support for WPA{2,3}-PSK, 802.11w and 802.11r. openwrt-ath79-generic-ubnt_nanostation-loco-m-squashfs-sysupgrade.bin sizes: 4719426 bytes (with wpad-basic-wolfssl) 4457282 bytes (with hostapd-basic-wolfssl) Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index f076eba88f..8c884386f2 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -204,6 +204,17 @@ define Package/hostapd-basic-openssl/description
This package contains a basic IEEE 802.1x/WPA Authenticator with WPA-PSK, 802.11r and 802.11w support.
endef
+define Package/hostapd-basic-wolfssl
+$(call Package/hostapd/Default,$(1))
+ TITLE+= (WPA-PSK, 11r and 11w)
+ VARIANT:=basic-wolfssl
+ DEPENDS+=+libwolfssl
+endef
+
+define Package/hostapd-basic-wolfssl/description
+ This package contains a basic IEEE 802.1x/WPA Authenticator with WPA-PSK, 802.11r and 802.11w support.
+endef
+
define Package/hostapd-mini
$(call Package/hostapd/Default,$(1))
TITLE+= (WPA-PSK only)
@@ -598,6 +609,7 @@ define Package/hostapd/install
endef
Package/hostapd-basic/install = $(Package/hostapd/install)
Package/hostapd-basic-openssl/install = $(Package/hostapd/install)
+Package/hostapd-basic-wolfssl/install = $(Package/hostapd/install)
Package/hostapd-mini/install = $(Package/hostapd/install)
Package/hostapd-openssl/install = $(Package/hostapd/install)
Package/hostapd-wolfssl/install = $(Package/hostapd/install)
@@ -668,6 +680,7 @@ endif
$(eval $(call BuildPackage,hostapd))
$(eval $(call BuildPackage,hostapd-basic))
$(eval $(call BuildPackage,hostapd-basic-openssl))
+$(eval $(call BuildPackage,hostapd-basic-wolfssl))
$(eval $(call BuildPackage,hostapd-mini))
$(eval $(call BuildPackage,hostapd-openssl))
$(eval $(call BuildPackage,hostapd-wolfssl))