aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-23 11:56:42 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 16:21:24 +0100
commit608d36e423fa7e105eb66e36aed943a19af02ba2 (patch)
tree5428961701ad945682e56a0121efefd2f0154fc1 /package
parent0dbdc2a98d877d4fd205e5139aa3ef9f3388eb1b (diff)
downloadupstream-608d36e423fa7e105eb66e36aed943a19af02ba2.tar.gz
upstream-608d36e423fa7e105eb66e36aed943a19af02ba2.tar.bz2
upstream-608d36e423fa7e105eb66e36aed943a19af02ba2.zip
uboot-layerscape-32b: simplify the package, it does not build anything
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-layerscape-32b/Makefile80
1 files changed, 16 insertions, 64 deletions
diff --git a/package/boot/uboot-layerscape-32b/Makefile b/package/boot/uboot-layerscape-32b/Makefile
index 8a338cdce4..852c83a929 100644
--- a/package/boot/uboot-layerscape-32b/Makefile
+++ b/package/boot/uboot-layerscape-32b/Makefile
@@ -6,7 +6,6 @@
#
include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
PKG_NAME:=uboot-layerscape-32bit
PKG_VERSION:=v1.0
@@ -17,82 +16,35 @@ PKG_MIRROR_HASH:=b62f4a55882ffb6b57da24ad9eaa98237141941d273e06a2244220a3e6b82ce
PKG_SOURCE_URL:=https://github.com/fsl-jyt/uboot-ls-32b.git
PKG_SOURCE_VERSION:=763de09cc7265e3147e2df2e15f91c73231907f4
-PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-
PKG_LICENSE:=GPL-2.0 GPL-2.0+
PKG_LICENSE_FILES:=Licenses/README
-include $(INCLUDE_DIR)/package.mk
-
-define uboot/Default
- TITLE:=
- CONFIG:=
-endef
-
-define uboot/ls1043ardb
- TITLE:=U-Boot binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1043ardb 32b Dev Board
- CONFIG=ls1043ardb-uboot.bin
-endef
-
-define uboot/ls1046ardb
- TITLE:=U-Boot binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 32b Dev Board
- CONFIG=ls1046ardb-uboot.bin
-endef
-
-define uboot/ls1012ardb
- TITLE:=U-Boot binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 32b Dev Board
- CONFIG=ls1012ardb-uboot.bin.swap
-endef
+PKG_MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
-UBOOTS := \
- ls1043ardb \
- ls1046ardb \
- ls1012ardb
-
-define Package/uboot/template
-define Package/uboot-layerscape-32b-$(1)
- SECTION:=boot
- CATEGORY:=Boot Loaders
- DEPENDS:= @TARGET_layerscape_32b
- TITLE:=$(2)
- URL:=https://github.com/fsl-jyt/uboot-ls-32b.git
- VARIANT:=$(1)
- MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
-endef
-endef
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
-define BuildUBootPackage
- $(eval $(uboot/Default))
- $(eval $(uboot/$(1)))
- $(call Package/uboot/template,$(1),$(TITLE))
+define Package/uboot-layerscape-32b
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ DEPENDS:=@TARGET_layerscape_32b
+ TITLE:=32-bit U-Boot for Layerscape boards
+ DEFAULT:=y
+ HIDDEN:=1
endef
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-endif
-
define Build/Configure
+
endef
define Build/Compile
-endef
-define Package/uboot/install/default
- $(CP) $(PKG_BUILD_DIR)/$(UBOOT_CONFIG) $(KDIR)/$(1)-32b-uboot.bin
endef
-define Package/uboot/install/template
-define Package/uboot-layerscape-32b-$(1)/install
- $(call Package/uboot/install/default,$(2))
+define Build/InstallDev
+ $(CP) $(PKG_BUILD_DIR)/ls1043ardb-uboot.bin $(KERNEL_BUILD_DIR)/ls1043ardb-32b-uboot.bin
+ $(CP) $(PKG_BUILD_DIR)/ls1046ardb-uboot.bin $(KERNEL_BUILD_DIR)/ls1046ardb-32b-uboot.bin
+ $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin.swap $(KERNEL_BUILD_DIR)/ls1012ardb-32b-uboot.bin
endef
-endef
-
-$(foreach u,$(UBOOTS), \
- $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-$(foreach u,$(UBOOTS), \
- $(eval $(call BuildUBootPackage,$(u))) \
- $(eval $(call BuildPackage,uboot-layerscape-32b-$(u))) \
-)
+$(eval $(call BuildPackage,uboot-layerscape-32b))