aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:50 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:22 +0200
commit60750ab505bae8d1cb70c6fe495b755b213a1ebf (patch)
tree66662b19fc1c98ed760389ba61ffe785e4a44e16 /package
parentf34b495a2eeebbd29bbd193d50eb490bc03fbde6 (diff)
downloadupstream-60750ab505bae8d1cb70c6fe495b755b213a1ebf.tar.gz
upstream-60750ab505bae8d1cb70c6fe495b755b213a1ebf.tar.bz2
upstream-60750ab505bae8d1cb70c6fe495b755b213a1ebf.zip
at91: reorganize at91 subtargets
reorganizing at91 subtargets based on sama5 soc features and this fix below problems. 1. able to set neon flags to sama5d2 & sama5d4 subtargets. 2. fix the make clean which removes all the subtargets in bin folder. 3. able to configure kernel specific to subtarget. 4. able to set vfpu4 flags to samad3 subtargets. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package')
-rw-r--r--package/boot/at91bootstrap/Makefile12
-rw-r--r--package/boot/uboot-at91/Makefile18
2 files changed, 20 insertions, 10 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index fbe44c424b..b350555c10 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -24,63 +24,73 @@ include $(INCLUDE_DIR)/package.mk
define AT91Bootstrap/Default
BUILD_TARGET:=at91
- BUILD_SUBTARGET:=sama5
HIDDEN:=1
AT91BOOTSTRAP_IMAGE:=at91bootstrap.bin
endef
define AT91Bootstrap/sama5d2_xplaineddf_uboot
TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d2_xplained
endef
define AT91Bootstrap/sama5d2_xplaineddf_qspi_uboot
TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (QSPI Flash)
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d2_xplained
endef
define AT91Bootstrap/sama5d2_xplainedsd_uboot
TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SDcard/EMMC)
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d2_xplained
endef
define AT91Bootstrap/sama5d3_xplainednf_uboot
TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (Nand Flash)
+ BUILD_SUBTARGET:=sama5d3
BUILD_DEVICES:=at91-sama5d3_xplained
endef
define AT91Bootstrap/sama5d3_xplainedsd_uboot
TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (SDcard)
+ BUILD_SUBTARGET:=sama5d3
BUILD_DEVICES:=at91-sama5d3_xplained
endef
define AT91Bootstrap/sama5d4_xplainednf_uboot_secure
TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (Nand Flash)
+ BUILD_SUBTARGET:=sama5d4
BUILD_DEVICES:=at91-sama5d4_xplained
endef
define AT91Bootstrap/sama5d4_xplaineddf_uboot_secure
TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SPI Flash)
+ BUILD_SUBTARGET:=sama5d4
BUILD_DEVICES:=at91-sama5d4_xplained
endef
define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SDcard)
+ BUILD_SUBTARGET:=sama5d4
BUILD_DEVICES:=at91-sama5d4_xplained
endef
define AT91Bootstrap/sama5d27_som1_eksd_uboot
TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard0)
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef
define AT91Bootstrap/sama5d27_som1_eksd1_uboot
TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef
define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index b8c6c6e965..fd58b9009e 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -40,55 +40,55 @@ endef
define U-Boot/sama5d3_xplained_nandflash
NAME:=SAMA5D3 Xplained board (NandFlash)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d3
BUILD_DEVICES:=at91-sama5d3_xplained
endef
define U-Boot/sama5d3_xplained_mmc
NAME:=SAMA5D3 Xplained board (SDcard)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d3
BUILD_DEVICES:=at91-sama5d3_xplained
endef
define U-Boot/sama5d2_xplained_spiflash
NAME:=SAMA5D2 Xplained board (SPI Flash)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d2_xplained
endef
define U-Boot/sama5d2_xplained_mmc
NAME:=SAMA5D2 Xplained board (SDcard/EMMC)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d2_xplained
endef
define U-Boot/sama5d4_xplained_spiflash
NAME:=SAMA5D4 Xplained board (SPI Flash)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d4
BUILD_DEVICES:=at91-sama5d4_xplained
endef
define U-Boot/sama5d4_xplained_mmc
NAME:=SAMA5D4 Xplained board (SDcard)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d4
BUILD_DEVICES:=at91-sama5d4_xplained
endef
define U-Boot/sama5d4_xplained_nandflash
NAME:=SAMA5D4 Xplained board (NandFlash)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d4
BUILD_DEVICES:=at91-sama5d4_xplained
endef
define U-Boot/sama5d27_som1_ek_mmc
NAME:=SAMA5D27 SOM1 Ek (SDCard)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef
define U-Boot/sama5d27_som1_ek_spiflash
NAME:=SAMA5D27 SOM1 Ek (QSPI Flash)
- BUILD_SUBTARGET:=sama5
+ BUILD_SUBTARGET:=sama5d2
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef