aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-11-16 20:20:30 +0000
committerJohn Crispin <john@openwrt.org>2013-11-16 20:20:30 +0000
commit5fbfffe7f4ff7014fe5c942ec0c179a745f340c0 (patch)
treea3461e928ac38b5b6b07934287da9dff7885421a /package
parentc4d8ddf1dc25f5ea55dda0a0f14209e1a4c6c78f (diff)
downloadupstream-5fbfffe7f4ff7014fe5c942ec0c179a745f340c0.tar.gz
upstream-5fbfffe7f4ff7014fe5c942ec0c179a745f340c0.tar.bz2
upstream-5fbfffe7f4ff7014fe5c942ec0c179a745f340c0.zip
procd: ubox: update to latest git head
move log service from procd to ubox some debloating on procd the preinit part of procd is now also a seperate binary Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38822
Diffstat (limited to 'package')
-rw-r--r--package/system/procd/Makefile11
-rw-r--r--package/system/ubox/Makefile12
-rw-r--r--package/system/ubox/files/log.init (renamed from package/system/procd/files/log.init)7
3 files changed, 17 insertions, 13 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 5c51f54752..6cce8045d0 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -1,14 +1,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2013-11-13
+PKG_VERSION:=2013-11-15
PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=f9d31edb8938341b9217ee4c14eb58111414eb97
+PKG_SOURCE_VERSION:=93d71ca996eb50b951169414cf541bf0fe4f647e
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -30,15 +30,12 @@ define Package/procd
endef
define Package/procd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d $(1)/lib
+ $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread,validate_data} $(1)/sbin/
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{init,procd,askfirst,udevtrigger} $(1)/sbin/
$(INSTALL_BIN) ./files/reload_config $(1)/sbin/
- $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
$(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
$(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
- ln -s /sbin/procd $(1)/sbin/init
endef
$(eval $(call BuildPackage,procd))
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index c913231505..15d222cb4e 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_VERSION:=2013-11-07.1
-PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
+PKG_VERSION:=2013-11-16
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=0588218d4bc58b0e099272338decbe4734f5678b
+PKG_SOURCE_VERSION:=b5dc53828bc69611cb474c95c9b23e70a2288391
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -36,9 +36,11 @@ define Package/block-mount
endef
define Package/ubox/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/ $(1)/etc/init.d/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader} $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,logd,logread,validate_data} $(1)/sbin/
+ $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib
ln -s /sbin/mount_root $(1)/sbin/switch2jffs
ln -s /sbin/mount_root $(1)/sbin/jffs2reset
ln -s /sbin/mount_root $(1)/sbin/jffs2mark
diff --git a/package/system/procd/files/log.init b/package/system/ubox/files/log.init
index cd7d9965a0..7676ec379b 100644
--- a/package/system/procd/files/log.init
+++ b/package/system/ubox/files/log.init
@@ -2,7 +2,7 @@
# Copyright (C) 2013 OpenWrt.org
# start after and stop before networking
-START=21
+START=12
STOP=89
USE_PROCD=1
@@ -50,6 +50,11 @@ service_triggers()
start_service()
{
+ procd_open_instance
+ procd_set_param command "/sbin/logd"
+ procd_set_param respawn
+ procd_close_instance
+
config_load system
config_foreach start_service_file system
config_foreach start_service_remote system