aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-17 17:12:02 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-17 17:12:02 +0000
commit5a8cbc6b7afc5a95f67b86fd110224f47b1fbef4 (patch)
tree973d748ca614c4d48785637c48ff05f41b27a4d1 /package
parentfaf725a77902ee5dd2f813cb4d2bebb5d3c63f74 (diff)
downloadupstream-5a8cbc6b7afc5a95f67b86fd110224f47b1fbef4.tar.gz
upstream-5a8cbc6b7afc5a95f67b86fd110224f47b1fbef4.tar.bz2
upstream-5a8cbc6b7afc5a95f67b86fd110224f47b1fbef4.zip
update ndisc6 to new upstream release (v0.5.0),
change Maintainer field in ipkg/control files, add tcptraceroute6 subpackage. git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2145 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/Makefile2
-rw-r--r--package/ndisc/Config.in33
-rw-r--r--package/ndisc/Makefile11
-rw-r--r--package/ndisc/ipkg/ndisc6.control2
-rw-r--r--package/ndisc/ipkg/rdisc6.control2
-rw-r--r--package/ndisc/ipkg/tcptraceroute6.control8
6 files changed, 42 insertions, 16 deletions
diff --git a/package/Makefile b/package/Makefile
index f46f13bdce..7b07613632 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -112,7 +112,7 @@ package-$(BR2_PACKAGE_MTR) += mtr
package-$(BR2_PACKAGE_MYSQL) += mysql
package-$(BR2_PACKAGE_NANO) += nano
package-$(BR2_PACKAGE_NCURSES) += ncurses
-package-$(BR2_PACKAGE_NDISC) += ndisc
+package-$(BR2_COMPILE_NDISC6) += ndisc
package-$(BR2_PACKAGE_NET_SNMP) += net-snmp
package-$(BR2_PACKAGE_NETSTAT_NAT) += netstat-nat
package-$(BR2_PACKAGE_NFS_SERVER) += nfs-server
diff --git a/package/ndisc/Config.in b/package/ndisc/Config.in
index 5aea49c8e8..fbf70a9a1b 100644
--- a/package/ndisc/Config.in
+++ b/package/ndisc/Config.in
@@ -1,30 +1,41 @@
-menu "ndisc - ICMPv6 discovery tools"
+menu "ndisc6 - IPv6 discovery tools"
-config BR2_PACKAGE_NDISC
+config BR2_COMPILE_NDISC6
bool
default n
- depends BR2_PACKAGE_NDISC6 || BR2_PACKAGE_RDISC6
+ depends BR2_PACKAGE_NDISC6 || BR2_PACKAGE_RDISC6 || BR2_PACKAGE_TCPTRACEROUTE6
config BR2_PACKAGE_NDISC6
- tristate "ndisc6 - ICMPv6 neighbour discovery tool"
+ tristate "ndisc6 - an ICMPv6 neighbour discovery tool"
default m if CONFIG_DEVEL
- select BR2_PACKAGE_NDISC
+ select BR2_COMPILE_NDISC6
help
- ICMPv6 neighbour discovery tools
+ An ICMPv6 neighbour discovery tools
- http://people.via.ecp.fr/~rem/ndisc/
+ http://people.via.ecp.fr/~rem/ndisc6/
config BR2_PACKAGE_RDISC6
- tristate "rdisc6 - ICMPv6 router discovery tool"
+ tristate "rdisc6 - an ICMPv6 router discovery tool"
default m if CONFIG_DEVEL
- select BR2_PACKAGE_NDISC
+ select BR2_COMPILE_NDISC6
help
- ICMPv6 router discovery tool
+ An ICMPv6 router discovery tool
- http://people.via.ecp.fr/~rem/ndisc/
+ http://people.via.ecp.fr/~rem/ndisc6/
+
+
+config BR2_PACKAGE_TCPTRACEROUTE6
+ tristate "tcptraceroute6 - a TCP/IPv6-based traceroute implementation"
+ default m if CONFIG_DEVEL
+ select BR2_COMPILE_NDISC6
+ help
+
+ A TCP/IPv6-based traceroute implementation
+
+ http://people.via.ecp.fr/~rem/ndisc6/
endmenu
diff --git a/package/ndisc/Makefile b/package/ndisc/Makefile
index cde15f218e..d12431c2ad 100644
--- a/package/ndisc/Makefile
+++ b/package/ndisc/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ndisc6
-PKG_VERSION:=0.4.0
+PKG_VERSION:=0.5.0
PKG_RELEASE:=1
-PKG_MD5SUM:=7c30f2bfdfc4bd7b7c986503083f218d
+PKG_MD5SUM:=affd992b2c797105cac4e2a478ba962d
PKG_SOURCE_URL:=http://people.via.ecp.fr/~rem/ndisc6/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -17,6 +17,7 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,NDISC6,ndisc6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,RDISC6,rdisc6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,TCPTRACEROUTE6,tcptraceroute6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
touch $@
@@ -39,3 +40,9 @@ $(IPKG_RDISC6):
install -m0755 $(PKG_BUILD_DIR)/rdisc6 $(IDIR_RDISC6)/usr/bin/
$(RSTRIP) $(IDIR_RDISC6)
$(IPKG_BUILD) $(IDIR_RDISC6) $(PACKAGE_DIR)
+
+$(IPKG_TCPTRACEROUTE6):
+ install -d -m0755 $(IDIR_TCPTRACEROUTE6)/usr/bin
+ install -m0755 $(PKG_BUILD_DIR)/tcptraceroute6 $(IDIR_TCPTRACEROUTE6)/usr/bin/
+ $(RSTRIP) $(IDIR_TCPTRACEROUTE6)
+ $(IPKG_BUILD) $(IDIR_TCPTRACEROUTE6) $(PACKAGE_DIR)
diff --git a/package/ndisc/ipkg/ndisc6.control b/package/ndisc/ipkg/ndisc6.control
index 91356525e4..0704436ff1 100644
--- a/package/ndisc/ipkg/ndisc6.control
+++ b/package/ndisc/ipkg/ndisc6.control
@@ -3,6 +3,6 @@ Priority: optional
Section: net
Version: [TBDL]
Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
Description: ICMPv6 Neighbour Discovery tool
diff --git a/package/ndisc/ipkg/rdisc6.control b/package/ndisc/ipkg/rdisc6.control
index 05df1176bb..c37b5c7810 100644
--- a/package/ndisc/ipkg/rdisc6.control
+++ b/package/ndisc/ipkg/rdisc6.control
@@ -3,6 +3,6 @@ Priority: optional
Section: net
Version: [TBDL]
Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
Description: ICMPv6 Router Discovery tool
diff --git a/package/ndisc/ipkg/tcptraceroute6.control b/package/ndisc/ipkg/tcptraceroute6.control
new file mode 100644
index 0000000000..c3fd2ffe1c
--- /dev/null
+++ b/package/ndisc/ipkg/tcptraceroute6.control
@@ -0,0 +1,8 @@
+Package: tcptraceroute6
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
+Description: A TCP/IPv6-based traceroute implementation