aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-07-02 18:04:17 +0200
committerJo-Philipp Wich <jo@mein.io>2021-07-02 18:49:21 +0200
commit5a1065758b88b568a04a50189400321601904bdf (patch)
treee24b5b0c061ff5fbaf2ff2638797cf797decd30e /package
parent8307da3dbdaff13d5ce99f8aefa32f5b7a2e18e6 (diff)
downloadupstream-5a1065758b88b568a04a50189400321601904bdf.tar.gz
upstream-5a1065758b88b568a04a50189400321601904bdf.tar.bz2
upstream-5a1065758b88b568a04a50189400321601904bdf.zip
iwinfo: build with nl80211 backend only and make shared
Drop support for building the obsolete broadcom-wl backend and always forcibly enable the nl82011 support. This allows us to make the package shared again since no target specific compilation is happening anymore. This will solve various repository coherency issues related to unavailable libiwinfo versions in the long run. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iwinfo/Makefile24
1 files changed, 5 insertions, 19 deletions
diff --git a/package/network/utils/iwinfo/Makefile b/package/network/utils/iwinfo/Makefile
index 9124e5fa07..3802d8d614 100644
--- a/package/network/utils/iwinfo/Makefile
+++ b/package/network/utils/iwinfo/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiwinfo
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/iwinfo.git
@@ -17,14 +17,6 @@ PKG_MIRROR_HASH:=f33779035153da6bd0b2f100f402f62f1554ab87ed6fbbd938d41df6b9947a1
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0
-PKG_FLAGS := nonshared
-
-PKG_CONFIG_DEPENDS := \
- CONFIG_PACKAGE_kmod-brcm-wl \
- CONFIG_PACKAGE_kmod-brcm-wl-mini \
- CONFIG_PACKAGE_kmod-brcm-wl-mimo \
- CONFIG_PACKAGE_kmod-cfg80211
-
IWINFO_ABI_VERSION:=20210430
include $(INCLUDE_DIR)/package.mk
@@ -34,13 +26,13 @@ define Package/libiwinfo
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Generalized Wireless Information Library (iwinfo)
- DEPENDS:=+PACKAGE_kmod-cfg80211:libnl-tiny +libuci +libubus
+ DEPENDS:=+libnl-tiny +libuci +libubus
ABI_VERSION:=$(IWINFO_ABI_VERSION)
endef
define Package/libiwinfo/description
- Wireless information library with consistent interface for proprietary Broadcom,
- nl80211 and wext driver interfaces.
+ Wireless information library with simplified API for nl80211
+ and wext driver interfaces.
endef
@@ -73,12 +65,6 @@ endef
define Build/Configure
endef
-IWINFO_BACKENDS := \
- $(if $(CONFIG_PACKAGE_kmod-brcm-wl),wl) \
- $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mini),wl) \
- $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mimo),wl) \
- $(if $(CONFIG_PACKAGE_kmod-cfg80211),nl80211)
-
TARGET_CFLAGS += \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
-I$(STAGING_DIR)/usr/include \
@@ -88,7 +74,7 @@ MAKE_FLAGS += \
FPIC="$(FPIC)" \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
- BACKENDS="$(IWINFO_BACKENDS)" \
+ BACKENDS="nl80211" \
SOVERSION="$(IWINFO_ABI_VERSION)"
define Build/InstallDev