aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2020-02-01 00:15:46 +0100
committerPetr Štetiar <ynezz@true.cz>2020-03-03 23:38:23 +0100
commit57432b964803d50889fb807b95367138bebce6fe (patch)
tree6e7d0a3d0237624bf4df7c3cb0efd59528971d8c /package
parente1516df0cd528ce9484b292ce2231434199fdb24 (diff)
downloadupstream-57432b964803d50889fb807b95367138bebce6fe.tar.gz
upstream-57432b964803d50889fb807b95367138bebce6fe.tar.bz2
upstream-57432b964803d50889fb807b95367138bebce6fe.zip
modules: fix dwc3-qcom wrong condition
Since now we support both kernel 4.19 and 5.2, change the condition to remove driver when on kernel 4.14 Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index c803c98b2d..e833c139a0 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -496,7 +496,7 @@ $(eval $(call KernelPackage,usb-dwc3-of-simple))
define KernelPackage/usb-dwc3-qcom
TITLE:=DWC3 Qualcomm USB driver
- DEPENDS:=@!LINUX_4_14 @(TARGET_ipq40xx||TARGET_ipq806x) +kmod-usb-dwc3
+ DEPENDS:=@(!LINUX_4_14) @(TARGET_ipq40xx||TARGET_ipq806x) +kmod-usb-dwc3
KCONFIG:= CONFIG_USB_DWC3_QCOM
FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-qcom.ko
AUTOLOAD:=$(call AutoLoad,53,dwc3-qcom,1)