aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-08-11 15:10:42 +0000
committerLuka Perkov <luka@openwrt.org>2013-08-11 15:10:42 +0000
commit556e850dfde6cd2a16237060212d2214d44adf13 (patch)
tree4740a5e304714da5273515f354fae17b7f9f67b7 /package
parent5337af031e4cb489f0bfc0ee9becea4eb39fb2db (diff)
downloadupstream-556e850dfde6cd2a16237060212d2214d44adf13.tar.gz
upstream-556e850dfde6cd2a16237060212d2214d44adf13.tar.bz2
upstream-556e850dfde6cd2a16237060212d2214d44adf13.zip
kernel: add imx-sdma-fw package
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 37753
Diffstat (limited to 'package')
-rw-r--r--package/kernel/imx/imx-sdma-fw/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/package/kernel/imx/imx-sdma-fw/Makefile b/package/kernel/imx/imx-sdma-fw/Makefile
new file mode 100644
index 0000000000..76392fe49d
--- /dev/null
+++ b/package/kernel/imx/imx-sdma-fw/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=imx-sdma-fw
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/imx-sdma-fw-$(PKG_VERSION)
+PKG_SOURCE:=imx-sdma-fw-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+PKG_MD5SUM:=49737c5fbee685cc1de2542c7663006d
+PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kmod-imx-sdma-fw-template
+ TITLE+=SDMA firmware for i.MX $(1) SoC
+ CATEGORY:=Kernel modules
+ SUBMENU:=Other modules
+ VARIANT:= imx$(1)
+ DEPENDS:=@TARGET_imx6
+endef
+
+define Package/kmod-imx-sdma-fw-template/description
+ SDMA firmware for Freescale i.MX SoC
+
+ http://comments.gmane.org/gmane.linux.ports.arm.kernel/210985
+endef
+
+Package/kmod-imx-sdma-fw-imx25=$(call Package/kmod-imx-sdma-fw-template,25)
+Package/kmod-imx-sdma-fw-imx31=$(call Package/kmod-imx-sdma-fw-template,31)
+Package/kmod-imx-sdma-fw-imx35=$(call Package/kmod-imx-sdma-fw-template,35)
+Package/kmod-imx-sdma-fw-imx51=$(call Package/kmod-imx-sdma-fw-template,51)
+Package/kmod-imx-sdma-fw-imx53=$(call Package/kmod-imx-sdma-fw-template,53)
+Package/kmod-imx-sdma-fw-imx6=$(call Package/kmod-imx-sdma-fw-template,6)
+
+define Build/Compile
+endef
+
+define Package/kmod-imx-sdma-fw-$(BUILD_VARIANT)/install
+ $(INSTALL_DIR) $(1)/lib/firmware/
+ $(CP) $(PKG_BUILD_DIR)/sdma-$(BUILD_VARIANT).bin $(1)/lib/firmware/
+endef
+
+$(eval $(call BuildPackage,kmod-imx-sdma-fw-imx25))
+$(eval $(call BuildPackage,kmod-imx-sdma-fw-imx31))
+$(eval $(call BuildPackage,kmod-imx-sdma-fw-imx35))
+$(eval $(call BuildPackage,kmod-imx-sdma-fw-imx51))
+$(eval $(call BuildPackage,kmod-imx-sdma-fw-imx53))
+$(eval $(call BuildPackage,kmod-imx-sdma-fw-imx6))