aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-04-14 23:21:19 +0200
committerPetr Štetiar <ynezz@true.cz>2021-02-14 09:31:30 +0100
commit50a5a8993d15fe090fdbf10fc25aba3f78c47d40 (patch)
treef4c80e8469c7c004faa93f453b1376a345f2992e /package
parenta45953c2f2c8c0c488eca13c2b8d9164a71ed5dc (diff)
downloadupstream-50a5a8993d15fe090fdbf10fc25aba3f78c47d40.tar.gz
upstream-50a5a8993d15fe090fdbf10fc25aba3f78c47d40.tar.bz2
upstream-50a5a8993d15fe090fdbf10fc25aba3f78c47d40.zip
uboot-imx6: bump to 2021.01 release
Refreshed all patches, removed 110-mx6cuboxi-mmc-fallback.patch as it seems, that upstream has probably added similar funcionality in commit 6c3fbf3e456c ("mx6cuboxi: customize board_boot_order to access eMMC") and it needs to be re-verified by device owner. Run tested on apalis. Cc: Felix Fietkau <nbd@nbd.name> Cc: Vladimir Vid <vladimir.vid@sartura.hr> Cc: Tim Harvey <tharvey@gateworks.com> Cc: Koen Vandeputte <koen.vandeputte@ncentric.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-imx6/Makefile4
-rw-r--r--package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch16
-rw-r--r--package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch15
3 files changed, 11 insertions, 24 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 79acd4abf7..549bebb7d2 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -7,10 +7,10 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=2020.04
+PKG_VERSION:=2021.01
PKG_RELEASE:=1
-PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
+PKG_HASH:=b407e1510a74e863b8b5cb42a24625344f0e0c2fc7582d8c866bd899367d0454
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch b/package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch
index 10ed918e77..8f8026faf9 100644
--- a/package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch
+++ b/package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch
@@ -1,4 +1,4 @@
-From 630b39c46b29de1874149c6b2c18c64966a0fabf Mon Sep 17 00:00:00 2001
+From 40fea3f6913086566586ba3a7304e28e670c9455 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
Date: Sun, 1 Mar 2020 22:47:31 +0100
Subject: [PATCH] apalis_imx6_defconfig: enable some useful commands
@@ -14,24 +14,26 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
configs/apalis_imx6_defconfig | 5 +++++
1 file changed, 5 insertions(+)
+diff --git a/configs/apalis_imx6_defconfig b/configs/apalis_imx6_defconfig
+index 1c791ab74846..4d21e9680747 100644
--- a/configs/apalis_imx6_defconfig
+++ b/configs/apalis_imx6_defconfig
-@@ -44,6 +44,7 @@ CONFIG_CMD_GPIO=y
- CONFIG_CMD_GPT=y
- CONFIG_CMD_I2C=y
+@@ -46,6 +46,7 @@ CONFIG_CMD_I2C=y
+ # CONFIG_CMD_LOADB is not set
+ # CONFIG_CMD_LOADS is not set
CONFIG_CMD_MMC=y
+CONFIG_CMD_PART=y
CONFIG_CMD_USB=y
CONFIG_CMD_USB_SDP=y
CONFIG_CMD_USB_MASS_STORAGE=y
-@@ -53,6 +54,10 @@ CONFIG_CMD_PMIC=y
+@@ -58,6 +59,10 @@ CONFIG_CMD_PMIC=y
CONFIG_CMD_REGULATOR=y
CONFIG_OF_CONTROL=y
- CONFIG_DEFAULT_DEVICE_TREE="imx6-apalis"
+ CONFIG_ENV_OVERWRITE=y
+CONFIG_CMD_EXT4=y
+CONFIG_CMD_EXT4_WRITE=y
+CONFIG_CMD_FAT=y
+CONFIG_CMD_FS_GENERIC=y
CONFIG_ENV_IS_IN_MMC=y
CONFIG_SYS_RELOC_GD_ENV_ADDR=y
- CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG=y
+ CONFIG_SYS_MMC_ENV_PART=1
diff --git a/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch b/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
deleted file mode 100644
index 9d490ddf7e..0000000000
--- a/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/board/solidrun/mx6cuboxi/mx6cuboxi.c
-+++ b/board/solidrun/mx6cuboxi/mx6cuboxi.c
-@@ -286,6 +286,12 @@ static void setup_iomux_enet(void)
- gpio_free_list_nodev(&desc, 1);
- }
-
-+void board_boot_order(u32 *spl_boot_list)
-+{
-+ spl_boot_list[0] = spl_boot_device();
-+ spl_boot_list[1] = BOOT_DEVICE_MMC1;
-+}
-+
- int board_phy_config(struct phy_device *phydev)
- {
- if (phydev->drv->config)