aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDaniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>2018-01-18 03:52:12 -0800
committerJo-Philipp Wich <jo@mein.io>2018-02-12 15:21:43 +0100
commit49d3c5f057768cfc6e0545267256c64baf19a4e2 (patch)
treed115a4d213ed1345e591fe1acb20bbf7ae1670c3 /package
parent8fdfba3d1a3d8db64c1c3b86a3f4818841147000 (diff)
downloadupstream-49d3c5f057768cfc6e0545267256c64baf19a4e2.tar.gz
upstream-49d3c5f057768cfc6e0545267256c64baf19a4e2.tar.bz2
upstream-49d3c5f057768cfc6e0545267256c64baf19a4e2.zip
kernel: add IEEE-1284 parallel port support
The kmod-lp package included both lp.ko and ppdev.ko, but ECP device drivers may or may not require lp NOT to be loaded, needing only ppdev. Additionally, There were no packages for any parport interface modules, such as uss720 or parport_pc, provided here. It has not been otherwise possible to use PC-style parport hardware for kmod-lp. Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk45
1 files changed, 40 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 12e05df416..11b44f875c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -286,18 +286,53 @@ endef
$(eval $(call KernelPackage,gpio-pcf857x))
-define KernelPackage/lp
+define KernelPackage/ppdev
SUBMENU:=$(OTHER_MENU)
- TITLE:=Parallel port and line printer support
+ TITLE:=Parallel port support
KCONFIG:= \
CONFIG_PARPORT \
- CONFIG_PRINTER \
CONFIG_PPDEV
FILES:= \
$(LINUX_DIR)/drivers/parport/parport.ko \
- $(LINUX_DIR)/drivers/char/lp.ko \
$(LINUX_DIR)/drivers/char/ppdev.ko
- AUTOLOAD:=$(call AutoLoad,50,parport lp ppdev)
+ AUTOLOAD:=$(call AutoLoad,50,parport ppdev)
+endef
+
+$(eval $(call KernelPackage,ppdev))
+
+
+define KernelPackage/parport-pc
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Parallel port interface (PC-style) support
+ DEPENDS:=+kmod-ppdev
+ KCONFIG:= \
+ CONFIG_KS0108=n \
+ CONFIG_PARPORT_PC \
+ CONFIG_PARPORT_1284=y \
+ CONFIG_PARPORT_PC_FIFO=y \
+ CONFIG_PARPORT_PC_PCMCIA=n \
+ CONFIG_PARPORT_PC_SUPERIO=y \
+ CONFIG_PARPORT_SERIAL=n \
+ CONFIG_PARIDE=n \
+ CONFIG_SCSI_IMM=n \
+ CONFIG_SCSI_PPA=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/parport/parport_pc.ko
+ AUTOLOAD:=$(call AutoLoad,51,parport_pc)
+endef
+
+$(eval $(call KernelPackage,parport-pc))
+
+
+define KernelPackage/lp
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Parallel port line printer device support
+ DEPENDS:=+kmod-ppdev
+ KCONFIG:= \
+ CONFIG_PRINTER
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/lp.ko
+ AUTOLOAD:=$(call AutoLoad,52,lp)
endef
$(eval $(call KernelPackage,lp))