aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-07-14 22:10:37 +0200
committerPetr Štetiar <ynezz@true.cz>2019-07-15 00:48:13 +0200
commit48662712b20fcf05e05b79800b6ec2a5bcbac96d (patch)
treeca3c2ce50379d279aa6766c4dfe8a9eae5712883 /package
parent1c3587cad9157c46d6ce82bce9a5300c65b52a30 (diff)
downloadupstream-48662712b20fcf05e05b79800b6ec2a5bcbac96d.tar.gz
upstream-48662712b20fcf05e05b79800b6ec2a5bcbac96d.tar.bz2
upstream-48662712b20fcf05e05b79800b6ec2a5bcbac96d.zip
fstools: add direct dependencies on libblobmsg-json and libjson-c
The OpenWrt buildroot ABI version rebuild tracker does not handle transient dependencies, therefore add all libraries linked by block-mount and blockd as direct dependencies to the corresponding binary package definition. This ensures that block-mount and blockd is automatically rebuilt and relinked if any of these libraries has its ABI_VERSION updated in the future. Fixes: FS#2373 [jow: similar fix for procd and 98.42% of commit message] Signed-off-by: Jo-Philip Wich <jow@mein.io> Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit cbae306815bdfc335eeedc35dc5df3d2d4021a2a)
Diffstat (limited to 'package')
-rw-r--r--package/system/fstools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 3aa250f7d4..4bc59150da 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -79,14 +79,14 @@ define Package/block-mount
SECTION:=base
CATEGORY:=Base system
TITLE:=Block device mounting and checking
- DEPENDS:=+ubox +libubox +libuci
+ DEPENDS:=+ubox +libubox +libuci +libblobmsg-json +libjson-c
endef
define Package/blockd
SECTION:=base
CATEGORY:=Base system
TITLE:=Block device automounting
- DEPENDS:=+block-mount +fstools +libubus +kmod-fs-autofs4
+ DEPENDS:=+block-mount +fstools +libubus +kmod-fs-autofs4 +libblobmsg-json +libjson-c
endef
define Package/fstools/install