aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 18:17:40 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 18:17:40 +0000
commit484609eeb06618dd2581f93ba57d0023a1f3adee (patch)
tree7f04a17039bdac5a306e1033a79e042b810051dd /package
parent91e5dba2c76d9185cc06c32feb51b8b0d1c310ca (diff)
downloadupstream-484609eeb06618dd2581f93ba57d0023a1f3adee.tar.gz
upstream-484609eeb06618dd2581f93ba57d0023a1f3adee.tar.bz2
upstream-484609eeb06618dd2581f93ba57d0023a1f3adee.zip
commit profile support for base-files... patches still need to be done
SVN-Revision: 6465
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5cbef91e3c..f02f1c9aa3 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -101,8 +101,13 @@ endef
define Package/base-files$(TARGET)/install
$(CP) ./files/* $(1)/
- if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
- $(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
+ if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
+ $(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
+ fi
+ if [ "$(PROFILE)" != "Default" ]; then \
+ if [ -d $(PLATFORM_DIR)/base-files/profile-$(PROFILE)/. ]; then \
+ $(CP) $(PLATFORM_DIR)/base-files/profile-$(PROFILE)/* $(1)/; \
+ fi; \
fi
$(SED) 's,$$$$R,r$(REV),g' $(1)/etc/banner
$(SED) 's,$$$$S,$(BOARD)-$(KERNEL),g' $(1)/etc/ipkg.conf