aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEike Ritter <git@rittere.co.uk>2021-03-14 18:50:21 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-19 00:25:58 +0100
commit46cd0765d0c585dc0b48c8c0a3f116ef83cd580f (patch)
treee37c8dc619a141b039137eff30e4bd60fa327b0e /package
parentc027dbac5a5222e6be4706a7a6a0effefce8ae76 (diff)
downloadupstream-46cd0765d0c585dc0b48c8c0a3f116ef83cd580f.tar.gz
upstream-46cd0765d0c585dc0b48c8c0a3f116ef83cd580f.tar.bz2
upstream-46cd0765d0c585dc0b48c8c0a3f116ef83cd580f.zip
ppp: compile fix: unset FILTER variable in Makefile
If the environment variable FILTER is set before compilation, compilation of the ppp-package will fail with the error message Package ppp is missing dependencies for the following libraries: libpcap.so.1 The reason is that the OpenWrt-patch for the Makefile only comments out the line FILTER=y. Hence the pcap-library will be dynamically linked if the environment variable FILTER is set elsewhere, which causes compilation to fail. The fix consists on explicitly unsetting the variable FILTER instead. Signed-off-by: Eike Ritter <git@rittere.co.uk>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/ppp/patches/610-pppd_compile_fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/network/services/ppp/patches/610-pppd_compile_fix.patch b/package/network/services/ppp/patches/610-pppd_compile_fix.patch
new file mode 100644
index 0000000000..4f66e5d71f
--- /dev/null
+++ b/package/network/services/ppp/patches/610-pppd_compile_fix.patch
@@ -0,0 +1,12 @@
+--- a/pppd/Makefile.linux
++++ b/pppd/Makefile.linux
+@@ -49,7 +49,8 @@ MPPE=y
+ # Uncomment the next line to include support for PPP packet filtering.
+ # This requires that the libpcap library and headers be installed
+ # and that the kernel driver support PPP packet filtering.
+-#FILTER=y
++# libpcap statically linked in OpenWRT, hence disabled here.
++FILTER=
+
+ # Support for precompiled filters
+ PRECOMPILED_FILTER=y