aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2020-06-28 21:40:06 +0300
committerDavid Bauer <mail@david-bauer.net>2020-07-28 15:52:44 +0200
commit444b107118212b4b5e822b9eb0937019dde1a4a1 (patch)
tree4f287585632f837f422a8c9d5454eddbe78e4cc6 /package
parentbcd7a0c0959545983b52ba3b038f17ec5f218847 (diff)
downloadupstream-444b107118212b4b5e822b9eb0937019dde1a4a1.tar.gz
upstream-444b107118212b4b5e822b9eb0937019dde1a4a1.tar.bz2
upstream-444b107118212b4b5e822b9eb0937019dde1a4a1.zip
atf-rockchip: update to 2.3
also install the firmware for all the supported boards Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com> [fix ATF blob path in uboot-rockchip] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package')
-rw-r--r--package/boot/arm-trusted-firmware-rockchip/Makefile6
-rw-r--r--package/boot/uboot-rockchip/Makefile2
2 files changed, 4 insertions, 4 deletions
diff --git a/package/boot/arm-trusted-firmware-rockchip/Makefile b/package/boot/arm-trusted-firmware-rockchip/Makefile
index a1c9e120e7..b712a3530a 100644
--- a/package/boot/arm-trusted-firmware-rockchip/Makefile
+++ b/package/boot/arm-trusted-firmware-rockchip/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=arm-trusted-firmware-rockchip
-PKG_VERSION:=2.3-rc0
+PKG_VERSION:=2.3
PKG_RELEASE:=1
PKG_SOURCE:=atf-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/atf-builds/atf/releases/download/v$(PKG_VERSION)/atf-v$(PKG_VERSION).tar.gz?
-PKG_HASH:=8d0a2bd18adf54f9cf6fe923d10f21c1d21f42a15067757333ff8989b25f100a
+PKG_HASH:=bf352298743aed594cf2958dd588e06ab6713fc514bb6f809bf55a85a87134c1
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=license.md
@@ -40,7 +40,7 @@ endef
define Build/InstallDev
$(INSTALL_DIR) -p $(STAGING_DIR_IMAGE)
- $(CP) $(PKG_BUILD_DIR)/rk3399_bl31.elf $(STAGING_DIR_IMAGE)/bl31.elf
+ $(CP) $(PKG_BUILD_DIR)/rk*.elf $(STAGING_DIR_IMAGE)/
endef
define Package/arm-trusted-firmware-rockchip/install
diff --git a/package/boot/uboot-rockchip/Makefile b/package/boot/uboot-rockchip/Makefile
index b99d051fcf..6e4139b098 100644
--- a/package/boot/uboot-rockchip/Makefile
+++ b/package/boot/uboot-rockchip/Makefile
@@ -35,7 +35,7 @@ UBOOT_TARGETS := \
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
UBOOT_MAKE_FLAGS += \
- BL31=$(STAGING_DIR_IMAGE)/bl31.elf
+ BL31=$(STAGING_DIR_IMAGE)/rk3399_bl31.elf
define Build/Configure
$(SED) s/subdir.*pylibfdt//g $(PKG_BUILD_DIR)/scripts/dtc/Makefile